Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> heater not workin
User Name
Password
lost password?   |   register now

Thread: heater not workin Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-26-2012 03:22 PM
nine4gmc he may be workin on it now. i agree with the thermostat checking BUT i would also check the vacuum line/connections going to the heater control valve, a 95 is a one of a kind critter as i found out the hard way with my yukon. it was totally different than my 94 and just as much different than 96-ups.
02-26-2012 02:36 PM
matts37chev probably never know
that was his #1 post
02-26-2012 02:19 PM
T-bucket23 Air pocket is also a possibility.
02-25-2012 04:55 PM
EOD Guy Very easy to check for a plugged heater core...... pull the heater hoses, hook one of them to a water hose, you don't have to clamp it on, just direct it into the pipe , if it's not plugged water will flow right thru
02-25-2012 11:44 AM
matts37chev the flush plugged the heater core, is my first thought
double check that thermostat
02-25-2012 11:23 AM
EOD Guy Bad themostat, has happened many times to me, put a new one in and no heat.
02-25-2012 10:22 AM
Fleetliner With the engine at normal operating temp. feel both heater hoses where they go through the fire wall. If both hoses are about the same temp. then the heater core is doing its job. If one hose is considerably cooler there is a restriction to the system.(plugged core) If the heater core is flowing and there is no heat out of the vents the problem is either the blend air door or the actuator for the blend air door is not operating. Most common is the door broken.
02-25-2012 08:10 AM
1putt or your heater core got clogged either from the flush or before or the thermostat was put in backwards or is dud. You can check it on the stove in boiling water and a pastry thermometer to see if it is opening and at what temperature.
02-25-2012 08:03 AM
75gmck25 I had similar problems with my 2000 Ford and it turned out the new Motorcraft thermostat was bad. Are you able to have someone plug in to the OBD diagnostic port to find out what temp the engine is getting up to? If its not getting up to about 195-200 degrees at idle with a stock thermostat, the thermostat is not working right.

The other possibility is that the heater blend door is broken or not working right. On a 95 it might be cable operated, but many newer cars use an electric actuator to set the position of the door.

Bruce
02-25-2012 07:59 AM
1putt was it blowing hot before you got it flushed and put in a new thermostat?
02-25-2012 07:44 AM
chrisjocko
heater not workin

my heaters not workin in my 95 chevy i got a radiator flush and new thermstat and now its blowing cold air

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.