Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Modern Electronic Engines> tbi 350 dumping too much fuel
User Name
Password
lost password?   |   register now

Thread: tbi 350 dumping too much fuel Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-31-2012 11:27 PM
andrews72400 my experiance is that it could be maf sensor either wrong vacume or its bad,also temp sending unit. both not to spendy to replace,
05-10-2012 06:20 PM
LATECH The fuel pressure too high? you have the jeep pump, in tank, for the multi point injection ...right.
I agree the FPR should only keep the pressure at the required 12-13 lbs for the tbi, regardless of the pumps capabilitys. Maybe the return line is blockked or pinched? that would shoot the fuel pressure up a lot.
If an injector was leaking on a TBI you would have 4 cylinders getting to much fuel
Have you checked the Fuel Pressure?
have you looked at ALL the plugs?
05-10-2012 01:42 PM
scott35
tbi 350 dumping too much fuel

i put a 92 tbi 350 in a 89 jeep wrangler run good when i first drove it but now its dumpimg too much gas it wont idle right it loads up and #8 plug is wet with gass all sensors check good put new fpr on it and also out a new temp sensor on it the only thing i have not replaced is the injectors any advicewould help ive only been running the motor harness i dont have the vehicle harness but it ran fine before

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.