Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics> Engine Assembly Lube of choice?
User Name
Password
lost password?   |   register now

Thread: Engine Assembly Lube of choice? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-18-2012 11:59 AM
Mr. P-Body Some good answers here. The idea of "pumping lifters up" prior to installation went away many years ago. The reasons sited in the quote from Comp is exactly right. I used to have a SnapOn "lifter pump" (looked like a pair of pliers with odd "ends"). Sold it in 1981... We actually srtarted setting "stem height" and counting the number of threads exposed above the nut, not unlike the "non-adjustable" Fords, Dodges, Pontiacs, etc. Makes for a much "nicer" engine when you don't have to "open" it again (valve covers).

The GM EOS idea is good. We've been doing it with STP for years. We use a noly-graphite "paste" on the lifter pottoms and rod bearings, "Mellube" or FM assembly lube on the mains and cam bearings, and 30 ND on the rings and pistons.

As long as it says "assembly lube" somewhere, you're usually okay. No white lithium, PLEASE! (it dosn't "blend" with engine oil)

Jim
05-18-2012 10:18 AM
Custom10 Pematex ultra stick assembly lube highly recommended. This stuff clings on better than a tick on a deers sack. For lifters I have never soaked or filled them before hand, engine preoiling with drill and an old gutted distributor (gear ground down) will put oil in the lifter after the valves are set.

Lifter face and cam lobes get a health dose of this ultra stick then the lifter gets a quick dunk in AC delco engine oil supplement and in they go. Put a full bottle of EOS into the lifter valley as well, on goes the intake. Never wiped a lobe, so far so good.
05-18-2012 09:34 AM
AutoGear Thats what I've always done; I guess I'll keep at it.
05-18-2012 09:21 AM
S10 Racer This was taken from Comp Cam's web site: I have always soaked mine in oil but never "pre-pump" them.

It is not necessary to “pre-pump” hydraulic lifters full of engine oil prior to installation and valve
adjustment. It is actually undesirable to do so as the “pumped up” lifters will cause the valves
to open during the adjustment process, rather than positioning the lifter plunger in its operating
position as it is supposed to do. “Pre-soaking” hydraulic lifters in a bath of engine oil is a good
idea but not mandatory. Doing so ensures that the lifters are adequately lubricated on their outer
surfaces prior to installation. It may also result in a quieter engine start up as the oil in the bath
may displace some air from the lifter’s plunger reservoir. Coat the bottoms of all flat tappet
05-18-2012 09:12 AM
1971BB427 Guess I've always done it wrong, as I soak my lifters overnight before dropping them in. I do wipe them off and use assembly lube on the outside before dropping them in though.
I've got 13 yrs./20,000 miles on my 427 now, and 4500 miles on my 327, and both were done this way with flat tappet hydraulic lifters.
05-18-2012 09:04 AM
AutoGear I suppose I should have specified. I would never use an assembly 'grease' for the pistons/rings. Im also not a fan of dunking the pistons in oil. Also, what are the current thoughts on soaking hydraulic lifters? I've heard a few people saying not to; in fact the Northern engine kits website specifically tells you NOT to which led to my questions
05-18-2012 08:50 AM
zildjian4life218 I have used clevites assembly lube and lucas semi synthetic that you can pick up right at autozone. That lucas stuff is very sticky and stringy. Motor oil on rings and pistons... as previously stated I don't think its good to have something too sticky on the rings.
05-18-2012 08:43 AM
1971BB427 I use Comp Cams 104 for all the bearings, but I use 30 wt. oil for the rings and pistons. I've always used motor oil for rings and pistons with no problems. I don't like to use anything too heavy on the cylinder walls, as I've been leary of it sticking to rings.
05-18-2012 08:14 AM
AutoGear
Engine Assembly Lube of choice?

When I was in school; the goo of choice was Lubriplate 105. Is this still the case? A lot of old farmers just used 30wt oil as long as you were going to run it ASAP. Ive also used petroleum jelly here at the shop to put gearboxes together (thick enough, dissipates easily in oil and cheap, however it does get really thin when its hot out). I just don't want to buy 37 different bottles to put together 1 shade tree 307

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 08:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.