Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Two questions about a BBC
User Name
Password
lost password?   |   register now

Thread: Two questions about a BBC Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-03-2012 02:55 PM
bigblockragtop 7 Years oh boy shows how much I was paying attention.
07-03-2012 09:13 AM
1971BB427 Always good to hear new ways to cool a BBC. I'm sure the original poster wont need it, but might help others now.
07-02-2012 10:04 PM
68NovaSS
Quote:
Originally Posted by RWENUTS View Post
Boy I sure hope he got it figured out. This thread is 7 YEARS OLD!!!!
We used to have a red banner warning posters a thread was old, but that didn't stop new members from posting to them.

Not that there's anything wrong with resurrecting an old thread I guess, but to offer a fix after all those years....
07-02-2012 08:18 AM
RWENUTS Boy I sure hope he got it figured out. This thread is 7 YEARS OLD!!!!
07-02-2012 06:15 AM
bigblockragtop I have a procharged 496 I moved to Arizona and had only a puller then I added a pusher to help cool things down and it worked. Just make sure the pusher is right against the radiator.
07-01-2012 11:22 AM
my87Z i would think that the two fans are fighting each other. one fan is trying to push the air out of the engine compartment and the other fan is trying to pull air through the radiator into the engine compartment.

another thing that is a little odd to me is a pusher fan being placed in between the radiator and the grill. any cfm it normally creats is being choked by the radiator causing a massive resistance on it before it can draw can even reach the engine compartment area.

correct me if i'm wrong and i have it backwards

I would think that a decent 4000cfm electric fan (puller) mounted between the radiator and the motor, you can get rid of the mechanical fan all together, would be more than enough to cool your engine.

i run a simple summit racing alm radiator with a Derale 4000cfm electric fan, a Weiand alm water pump, and a 180 thermo. I dont have my transmission oil running to the radiator though I have an additional ATI electric trans cooler for that. I take my car twice a year to the Cruzin in Ocean City, MD and trust me that can be stop and go traffic for over an hour. I also race my car regularly at the track and i have never seen my engine get above 190, nor my transmission get above 160.
07-01-2012 11:08 AM
Greg T Check with your engine builder and ask about the clearances. If he has them on the tighter side and you're only driving on the street you may better off with 5W-30 oil.



.
07-01-2012 10:43 AM
Wolf Wengler I'm running a 502 with a Griffin with a 13-pound cap and a (IF I REMEMBER RIGHT) A Weiand aluminum pump and a 17inch flex-fan. I have no cooling problems what so ever. With a 160 TStat it runs 160 with a 195 it runs 195. Make sure the shroud is sealed up close to the Rad. The electric fan infront may be doing more harm than good. Good luck
Water wetter also does work.
01-31-2009 03:57 PM
Overdrive1939
Fans?

I have used a number of different fans and found the the pusher type to be not as effective as the puller type in cooling the car. I do not gun any mechanical fan driven by the engine directly (HP Drain). Have you tried raising the pressure on the cap for example from 12psi to 16psi. The rise in pressure will raise the boiling temp in the coolant so if the car does go to 200 deg. you will have more room to run slightly warmer. I live in on the coast of North Carolina and we see temp here of 90 to 100 deg. I( have a 502 in a 39 Chevy with a Griffin rad. Hope I didn't bore you to bad. Good luck!
05-28-2005 02:00 AM
GoneNova/406 rob
you're right on with the fans.i have a large griffin 2 core also and with the added volume it takes more to push the needed amount of water.i bought an aluminum stewart stage 2 water pump to go with it and my problems at stop lites were over.the info i have says that the GM aluminum water pump used on the famed ZZ430 #12495826 is nearly as good not quite but adaquate.also the edelbrock rpm alum. pump is as good.if you go with a stewart they like to tell you what you need and you may buy two pumps before getting what you need.i did.you'd think they'd know but know body knows your motor and system like you do so you may need to be forceful with them.i have the stage one sitting on the shelve collecting dust. last thing is if your temps in the summer get very hot you may want to go stiffer on your oil,10-40,20-50 or better yet synthetic and go back for winter.other that that it sounds like you have it handled.good luck
05-27-2005 10:18 PM
RObs71Nova
Two questions about a BBC

Hi guys.

I have a 454 in my 71 Nova and I had a two questions I hope you all can help me with.

First one is:

I have a Griffin 2 core aluminum radiator in the car, along with my mechanical fan and a fan shroud. I also have an electric fan inbetween the grill and the radiator, which I believe is called a "pusher". I have searched through the other threads and seen this a few times, but could the pusher fan be hurting more than helping? I have the fan rigged on a toggle switch and I shut it off at highway speeds, then turn it on at a stoplight/drivethru. Would that be the best thing to do? Like I am doing it now? I do not have room to put the fan anywhere else. Right now the motor does not really run hot, with its cruising temp about 180 and it creeps to about 200 at a drive-thru, but it is only in the high 80's here right now, and it will be in the high 90's/low 100's here before too long and I dont know if the motor will start running hot when that happens. Would it be worth it to run a bottle of "Redline Water Wetter" in the radiator, or some "Purple Ice"? I know there are different opinions as to wether the stuff works or not, but even if it helps cool 4-5 degrees, thats something right? (Sorry for all the questions)

The second main questions I had is this:

What weight synthetic motor oil should I use in my motor? The motor is professionally rebuilt on the bottom end, rebuilt to stock, and has aftermarket heads/cam/intake, etc. to the tune of where it is pushing around 425 flywheel horsepower. The temperature around here never sees anything below 30 degrees, (no really cold starts) and regularly sees the high 90s in the summer. Right now I'm having a problem with my heads holding oil and I think by switching to a different weight oil it may help my problem. Right now I run 20w-50 but I was thinking of maybe switching to a 10w-30?

Thanks alot for any help you guys can give. It is VERY much appreciated.

Rob

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.