Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> rebuilt 350, burning oil just like the engine I replaced?
User Name
Password
lost password?   |   register now

Thread: rebuilt 350, burning oil just like the engine I replaced? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-17-2012 04:16 PM
JesseShredd Wouldn't be a chance of it running too low of a temapture? and kinda skeptical about the price difference. Don't wanna pay more for the more I don't need Haha.
07-17-2012 04:10 PM
dsraven go with the 3 core rad. you know what they say, go big or go home. also have a new thermostat installed at the same time, and not one of those knock offs, a real gm thermostat. I have had lots of trouble with the cheap thermostats and then finally put in a gm one and problem is solved.
07-17-2012 03:57 PM
JesseShredd Getting an aluminum v8 radiator, should I go 2 core or 3?
07-16-2012 07:03 PM
dsraven make sure to check the intake without a gasket so you know for sure about any spaces etc. also, make sure the gasket is installed right becaus those rear ports are sometimes covered so the coolant flow goes the right way without short cutting.
other things to check
-pcv valve and baffled cavity in valve cover under the pcv to make sure it isn't sucking oil in that way. some aftermarket covers don't have much for baffles under there.
-auto trans vacuum hose (if equipped) to modulator valve. if modulator valve is leaking the engine can suck up trans oil.
-document how much oil is being used. check it the same way every time-like if it is hot and just shut off or, if it is hot and has sat for several minutes so the oil has had a chance to find it's way back to the oil pan- making the level higher than if checked right after shut down.
-make sure it is engine oil and not trans fluid or coolant.
-pressure test the cooling system to make sure you are good to go there. did you flush the rad etc before assembly was finished? is the core clean on the inside?
-are all the plugs burning the same as far as what colour they are when you take them out? a dark plug can tell you that cyl is getting oiled or fueled more than the rest. make sure to have the proper reach on the plug and correct heat range. too long of a reach can cause hot running, as can too hot of a heat range.
keep us posted.
07-16-2012 05:31 PM
JesseShredd Thanks for your word, I will make sure everything aligns up while installing the edelbrock intake gaskets. Looks like I'll be purchasing a new radiator! Found a 4th gen camaro
dual fan also...anyone heard of making them fit a thirdgen?
07-16-2012 05:01 PM
dsraven you definately need a v8 rad. also. if you don't have info on the rebuild, check to see if there is a rebuild tag or work order number stamped somewhere on the block. ask around who might have that kind of stamp. you may be able to get some info from the builder. when you take the manifold off to replace the gaskets, check to see if the intake fits the heads. sometimes the head gasket surfaces get machined and that makes the mating angles to the intake manifold wrong. it can leak oil or air. both could cause the problem you are having. a lean running engine will run hot, also oil sucked into the manifold plenums will cause smoke. it happened to a friend of mine who had an olds engine. the shop had to plane the heads a bunch and put them on anyway. mostly because they couldn't find another set to fit. it ran hot and smoked, aspecially when hot because the oil got thinner maybe.
just a thought.
07-16-2012 04:42 PM
JesseShredd 180 degree thermostat. Radiator looks identical to my 89 305 camaro
07-16-2012 04:36 PM
FmrStrtracer
Quote:
Originally Posted by JesseShredd View Post
Amy suggestions on what to do about the engine running hot would be appreciated. I let all the air out of the system yesterday, which didn't make a difference.
You need more radiator.

What thermostat are you using.
07-15-2012 09:31 PM
JesseShredd Will be replacing the intake manifold gaskets with edelbrocks. I will let everyone know how it turns out. In the meantime, Amy suggestions on what to do about the engine running hot would be appreciated. I let all the air out of the system yesterday, which didn't make a difference.
07-15-2012 06:30 PM
JesseShredd I have the fan wires to a killswitch which I leave on all the time while running. Timig has been set, compression is good, spark plugs are in good shape also last time I checked.
07-15-2012 06:08 PM
FmrStrtracer YES, you need a V8 cooling system.

Are you just letting the car sit and idle until it gets Hot? You should at least have a house or shop fan blowing across the radiator.

Before you start swapping parts, check the timing, pull the plugs and inspect them. Also do a compression test to check the condition of the motor.

Report back and we'll help from there.
07-15-2012 04:33 PM
JesseShredd The valve is the same since I already had the manifold and carb, just threw it on but it looks brand new and no oil is in it after running to normal temperature.
07-15-2012 04:14 PM
TexasDave Did they replace the PCV valve?
07-15-2012 04:03 PM
JesseShredd Also, since the car had a v6 stock, I'm assuming the radiator and fan cant support enough cooling for my current 350 5.7? Gonna be driving in a week so I would like to have this all squared away.
07-15-2012 03:36 PM
JesseShredd That would be great, or if you can recommend something similar that would help. This sounds like a good investment to make regardless cause I am using felpro intake gaskets.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.