Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> Starter wire got extremely hot fried the ground wire
User Name
Password
lost password?   |   register now

Thread: Starter wire got extremely hot fried the ground wire Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-04-2012 02:32 PM
ttjsk812@aim.com Here it is. No power on inside of vehicle. bad ignition?
08-03-2012 07:42 PM
S10 Racer The negative cable from your battery needs to be grounded to the engine block. Then you should have ground cables or straps from the engine to the frame and body. You can't have too many grounds but they all need to be the correct size and grounded properly. If you could post a picture of your engine compartment showing what you have it would be easier to diagnose. Never use a header bolt for a ground point. Header bolts come loose in time and will cause you problems.
08-03-2012 07:32 PM
ttjsk812@aim.com yes yes its grounded to the header but I think its called the ground strap maybe
08-03-2012 06:47 PM
S10 Racer Where is your battery negative (big) cable grounded to on the truck? It should be grounded to the engine.
08-03-2012 04:34 PM
ttjsk812@aim.com
Starter wire got extremely hot fried the ground wire

Hi guys I have an s10 with a sbc. Just went to start truck and it fired but saw and smelled something under hood.. One of the wires or all of the wires (idk) got extremely hot and melted the plastic wire loom tubing. I also the in a glance the ground wire from the battery to the body smoking and it obviously fried that because the radio was starting to fade. I do know that I was concerned about replacing the ground before because it smoked a little on occasion but do you think it just couldnt handle the current from being wore out already and the starter wire got extremely hot? or is my starter going bad?? Remember its the ground from the battery to the body not the thick negative terminal itself..

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 05:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.