Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Big Block high speed over heat
User Name
Password
lost password?   |   register now

Thread: Big Block high speed over heat Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-22-2012 10:47 PM
cdminter59
Big Block high speed over heat

The radiator you are using is this the original radiator. Did the Camaro originally come with the 396 Cid. Is it a four core radiator? Do you have the fan shroud for a 1969 big block radiator? There are two one is for 23" radiators and the other is for 20 3/4 radiators. Can you get a Infrared Thermometer Gun to check the block temp, temp head, radiator, etc. You can see hot spots in the block and heads. Need some more info such as last time engine was rebuilt, clutch fan. Cast iron or aluminum heads. Have you done a compression test or leak down test for checking the head gaskets.
08-22-2012 09:09 PM
ghost ridder Thanks for the input. I will take another look at the lower hose.
I have been looking at the more modern cooling system but I am tryin g t;o stay original if I can. I have played with the I have reduced some of the high temp.
08-11-2012 09:47 PM
xzero117 check your hoses, maybe you should think about investing in a modern cooling system, aluminum radiator and electric fans
08-11-2012 09:18 PM
RWENUTS Do you have a coil in your bottom rad hose? Could be collapsing stopping flow.
Do you have an airdam or chin spoiler on your car? You need to create a low pressure area behind your rad so the air will flow in the front.
08-11-2012 08:13 PM
ghost ridder
Big Block high speed over heat

I have a 1968 Camaro with a 1969 396 hsp big block. I have a 180 degree thermostate in it that runs at 193 degrees. When I hit the hgihway 55 mph or higher the temperature rises above 200 degrees. I have had the radaitor and cap checked at Ann Arbor Radaitor, no problem. Replaced water pump with high volume pump. Heads have been redone with hard seats to burn the unleaded gas. New Elderbrook carb and aluminum intake. Still the same results.

Any ideas.

Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 08:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.