Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> demon carb stumble @wot
User Name
Password
lost password?   |   register now

Thread: demon carb stumble @wot Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-13-2012 04:52 PM
cdminter59
demon carb stumble @ wot

Be sure to check all ignition components carefully. Distributor cap, rotor, correct spark plugs gaped at .035, make sure spark plug wires are not touching headers. Timing set at 24* BTDC. Check valve lash again. Here is the manual for the Mighty Demon. It shows how to tune your Demon carburetor. http://www.demoncarbs.com/Assets/doc.../LIT705rev.pdf. You will need a vacuum gauge and a timing light with advance. Here is another article on how to set up your distributor. http://www.crankshaftcoalition.com/w...EI_distributor
09-13-2012 03:34 PM
bill6368 last it was checked using a light it was @26 deg
09-13-2012 03:25 PM
bill6368 Im not sure ive tried it at dif spots it stumbles even in park a little but its worse when i leave out the hole
09-13-2012 03:18 PM
lg1969 What is timing set at?
09-13-2012 03:07 PM
bill6368 Im not running a vac advance got it plugged off you think i should hook it back up
09-13-2012 02:55 PM
lg1969 Disconnect the vacuum advance and bring the timing more advance another 10*. Adjust the idle down. Reconnect the vacuum line. The idle should increase when you advance the timing. Try to adjust A/F screws.
09-13-2012 12:30 PM
bill6368
demon carb stumble @wot

i got a 355 sbc foot brake car i put a 750 mighty demon on it im having a dead spot @wot then it picks up an does fine ive tried the slot transfer seems if i close it up where it needs to be it idles at very low rpm also the air fuel mix screws if you turn them all way it seems to idle up the motor

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.