Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> 94 chevy no power
User Name
Password
lost password?   |   register now

Thread: 94 chevy no power Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-27-2012 11:08 PM
cdminter59
94 chevy no power

Do you do all the work on your truck? This sounds like a problem that may take some testing of sensors, your fuel pump pressure. Start out getting a can of carburetor cleaner, spray along the intake & heads, front and back of intake, and base of throttle body. This is cheap and eliminates vacuum leaks. Things that make the engine use more gas: EGR Valve, EGR solenoid, coolant temp sensor, knock sensor, intake air sensor, plugs, plug wires, camshaft position sensor, ignition module, and the PCM computer. With all these electrical parts in my opinion it would be best to have it check by the dealer. This way you are not buying parts you don't need. They will hook it up to an engine analyzer to find the problem.
09-27-2012 09:42 PM
rickman2k
should be TBI

sounds like the fuel system is going bad, the filter in the gas tank could be clogged over, the fuel filter could be full, or the fuel regulator inside the throttle body (TBI) could need replacing. With it sucking down gas I'd check the regulator first
09-27-2012 09:17 PM
allansmith859 The truck does have TPI EFI and its all stock. I bought the truck not long ago. I used to have the same truck but a 93 modle and it wasn like this. regardless i plan on getting a intake and maybe upgrade the EFI but first I would like to figure out why it has no power. Im pretty sure there are no vaccum leaks. I am clueless. It kinda seems hesitant when I hit the throttle
09-26-2012 10:25 AM
joe_padavano Did this happen all of a sudden? Simply swapping an intake is NOT going to fix a problem. Could be ignition, throttle body, vacuum leak, or a number of other problems, none of which will throw a code. Throwing parts at the truck without troubleshooting first is a good way to waste a lot of money. If you have that much extra cash, send some my way. Otherwise, do some proper troubleshooting first.
09-26-2012 08:20 AM
cdminter59
94 chevy no power

Does this truck have a TPI EFI system on a 350 motor. Have you made any changes to the motor? If yes please list all the changes you have made.
09-26-2012 06:09 AM
allansmith859
94 chevy no power

Hey guys I have a 1994 chevy 1500 2wd and it has no power what so ever. It is using gas like u wouldn believe. If Im at a stop and put the gas pedal to the floor it doesnt go like it should. While Im driving I have the same problem. The truck runs great, the engine light isnt on, it almost like it has something to do with the intake or throttle body. It simply just does not have power. You can here it suckin the gas down. I can see the gas gauge move, no joke. Was thinking about buying a new intake manifold from jegs and trying that. If that helps out a little then I was thinkin about putting a performer carb on it. Whats your all opinion on this????

Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.