Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics> oil pressure sending unit leaks
User Name
Password
lost password?   |   register now

Thread: oil pressure sending unit leaks Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-03-2012 11:38 AM
cobalt327 Plastic line can be run inside vacuum tubing to protect it and prevent kinks. Similar to how the OEM did w/copper tubing- before they discontinued using it in favor of steel or plastic, they used a bonded rubber outer covering on them especially in places where there could be contact w/anything. The factory also used a double loop at the end to help keep the copper line from breaking from metal fatigue or work hardening and to compensate for temp changes.

If the line is going to be changed, change it to something that's better than either: Braided Stainless Steel Mechanical Gauge Hose Kit
10-02-2012 06:53 PM
66GMC
Quote:
Originally Posted by S10 Racer View Post
Do yourself a favor and replace the plastic line with copper. I had a 68 RS SS Camaro with the plastic line and it broke at the gauge in the console and pumped 4 qts. of oil in my floorboard before I knew what was wrong.
Ditto.
Do it right.
Do it once.
10-02-2012 05:18 PM
S10 Racer Do yourself a favor and replace the plastic line with copper. I had a 68 RS SS Camaro with the plastic line and it broke at the gauge in the console and pumped 4 qts. of oil in my floorboard before I knew what was wrong.
10-02-2012 03:28 PM
Live Action!
OIl pressure fittings

I didn't mean but silcone all over the place just the treaded area's must be reading to hard into it!
10-02-2012 03:26 PM
Live Action!
oil pressure fitting

Worked for me! keep on keepin on!
10-02-2012 03:01 PM
Lthompson ive tried two kits so far. Both leaked. Guess ill try again.
10-02-2012 11:24 AM
RWENUTS Bad idea!
Use a sealer for the fitting into the block but never use sealer on a compression or flared fitting. JMHO
10-02-2012 10:49 AM
Live Action!
Oil line leak

I had the same problem when I installed mine, when you screw in the fitting going on to the manifolid I use permatex utra cooper silcone around threads. Next put the plastic tubing throught the cuplink then the little cuplink with enough tubing to fit a the way down aplly the silcone around those threads also. last tighten down and make sure your not cross threading, do the same to the guage in the car the silcone will prevent it from leaking. If all else fells Autozone has a kit that comes with the tube and fitting for like $5 bucks to start over. Hope this helps
10-01-2012 07:06 PM
66GMC
Quote:
Originally Posted by cobalt327 View Post
After a compression fitting is taken off and on a few times they can get to the point where they no longer seal. If you have a plastic line, cut it squarely to remove the ferrule that's crimped onto the line.

Most any parts house will sell you a small bag of replacement ferrules for a pittance, reuse the rest of the fitting as long as the threads are OK.

The complete fitting part number is a Weatherhead # 68x2 (Retail $1.40 CDN)
which is 1/8 NPT pipe thread on one end (which screws into the engine), and the other end is a 1/8" tube compression fitting.

You can buy JUST the ferrule if you like.
Weatherhead P/N for that is 60x2. (Retail $0.17 CDN)

Also ... I dislike / distrust plastic tubing as I had a bad experience. My brother borrowed my car, and the tubing blew out of the fitting. It's amazing how quickly you can drain an oil pan out of a 1/8" diameter hole with a high-volume oil pump.

To complicate matters, he broke the brass fitting off clean at the engine while attempting to tighten things up again. (He was 17, I was 21 at the time.)

Needless to say, there were a few cuss-words uttered as I used an easy-out to remove the broken fitting.

I played it safe, replaced the platic tubing with copper. Yes, I made the line long enough to add a couple of 3" loops to accomodate engine movement and vibration.
10-01-2012 06:22 PM
cobalt327
Quote:
Originally Posted by Lthompson View Post
My oil pressure guage is the type that has the little oil line that runs from the back of the motor. Ive tried several times but it has always leaked right where the hose goes into the brass fitting going into the motor. What is the trick to getting these to not leak?
After a compression fitting is taken off and on a few times they can get to the point where they no longer seal. If you have a plastic line, cut it squarely to remove the ferrule that's crimped onto the line.

Most any parts house will sell you a small bag of replacement ferrules for a pittance, reuse the rest of the fitting as long as the threads are OK.

10-01-2012 03:47 PM
RWENUTS If this is the style of hookup you have then you need to replace the little sleeve in the middle. It slides over the tube and is compressed to seal inside the fitting.
How To Indetify Fittings Another Style Compression Fitting Photo 19
10-01-2012 03:17 PM
Lthompson
oil pressure sending unit leaks

My oil pressure guage is the type that has the little oil line that runs from the back of the motor. Ive tried several times but it has always leaked right where the hose goes into the brass fitting going into the motor. What is the trick to getting these to not leak?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.