Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics> Carb ? please help!
User Name
Password
lost password?   |   register now

Thread: Carb ? please help! Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-02-2012 05:49 PM
Irelands child Get your instruction book out that came with the carb - or if it has disappeared, Edelbrock has it posted on line: http://www.edelbrock.com/automotive_...406_manual.pdf

It can be confusing so you do need to spend some time understanding what does what.
10-02-2012 04:34 PM
Live Action!
Carb Help

Thanks I'll try that first!
10-02-2012 12:21 PM
RWENUTS It's about timing!
SEt your timing at 12* and hook your vacuum pot up to manifold vacuum. Slow your idle back down and you'll have the carb back in sync. Rich smell is caused by uncovering the idle transfer slot too much and getting into the power circuit too soon.
10-02-2012 11:30 AM
Live Action!
Carb ? please help!

I have a 1406 carb edelbrock and I'm get arich exhuast smell, checked plugs there fine. I also read that the primary butterflies opened to far it will cause this. My ? is how do I ajust them or what cause's them to open to far. I aslso have electric chocke hooked up do I adjust it there? Like to thank you ahead of time!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.