Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> vega steering
User Name
Password
lost password?   |   register now

Thread: vega steering Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-05-2012 02:27 PM
Deuce
Quote:
Originally Posted by JOHNSHENOUDA View Post
I installed a vega box on my 30 model A. The car has a 302. Yes imagine that a Ford in a Ford. The space for the steering rod inside the gap of the motor mount looks very tight. Any suggestions?
Install a Chevy engine

The Ford SBF does present it's own set of issues. The oil filter being one of them. I used a Mustang box in a 32 a long time ago. It had a 289/C4 combination. It was for a customer. No photos ... but it was very similar to the stock 32 system ( side steer )

.
10-02-2012 12:31 PM
RWENUTS Take a pic so we can see what you're working with.
10-02-2012 10:04 AM
JOHNSHENOUDA
vega steering

I installed a vega box on my 30 model A. The car has a 302. Yes imagine that a Ford in a Ford. The space for the steering rod inside the gap of the motor mount looks very tight. Any suggestions?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 03:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.