Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge> The "What Did You Work On Today" thread
User Name
Password
lost password?   |   register now

Thread: The "What Did You Work On Today" thread Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
Yesterday 09:26 PM
John long
Quote:
Originally Posted by Too Many Projects View Post
I welded the front of the trunk pan to the floor pan and a patch in the left wheel house.

Then I put my '62 Impala on stands to remove the transmission. I put water in the radiator last week and it dripped out the back of the block. BOTH of the frost plugs on the back are leaking. Can't believe someone would not use a sealer back there. Possibly worse, I think the cam hole plug is leaking oil too.

Bummer. At least it will be a cheap fix......Hmmmm, does that mean we would call it a frugal fix?

John
Yesterday 09:10 PM
John long
Quote:
Originally Posted by 496CHEVY3100 View Post
What are the 4 faces,
Playing with new spot blaster.
Yesterday 09:00 PM
tech69 another day of knocking it out. I can't wait til this weekend to get my HF roller and get started on this frame. It's crazy when you have work logs and you can see who the slow pokes are-lol. Don't be a slow poke fellas. Can't get anything done being a slow poke.
Yesterday 08:33 PM
Too Many Projects I welded the front of the trunk pan to the floor pan and a patch in the left wheel house.

Then I put my '62 Impala on stands to remove the transmission. I put water in the radiator last week and it dripped out the back of the block. BOTH of the frost plugs on the back are leaking. Can't believe someone would not use a sealer back there. Possibly worse, I think the cam hole plug is leaking oil too.

Yesterday 08:25 PM
Too Many Projects
Quote:
Originally Posted by 1971BB427 View Post
My replacement wheel came via the brown truck today! The last 15"x4" Torq Thrust II in the USA, and fortunately Summit had only this one left! Got the local tire store to mount it up, and tomorrow I'll shoot the darker gray center on it.
.
There are places that will repair that wheel. Aluminum is actually fairly easy to bend back.

Here's one Rim Repair | Wheel Repair | Alloy Wheel Repair | Bent Rim
Yesterday 08:24 PM
matts37chev
Quote:
Originally Posted by 1971BB427 View Post
My replacement wheel came via the brown truck today! The last 15"x4" Torq Thrust II in the USA, and fortunately Summit had only this one left! Got the local tire store to mount it up, and tomorrow I'll shoot the darker gray center on it.


Sad part was the "Made in China" label on it. American Racing sold in 2008, and all their wheels are made in China since selling to Wheel Pros. If I didn't need it so badly, I'd have passed on it. The machine work on the "polished" rim is not up to the standard of the bent wheel it replaced.
well now you have a cool garden hose holder
Yesterday 07:10 PM
1971BB427 My replacement wheel came via the brown truck today! The last 15"x4" Torq Thrust II in the USA, and fortunately Summit had only this one left! Got the local tire store to mount it up, and tomorrow I'll shoot the darker gray center on it.


Sad part was the "Made in China" label on it. American Racing sold in 2008, and all their wheels are made in China since selling to Wheel Pros. If I didn't need it so badly, I'd have passed on it. The machine work on the "polished" rim is not up to the standard of the bent wheel it replaced.
Yesterday 05:22 PM
496CHEVY3100
Quote:
Originally Posted by MARTINSR View Post
HUH?

Brian
I posted a wrong post to this site ,,I removed it
Yesterday 04:34 PM
MARTINSR I know this isn't what I did today on a car....well, I did install a seat on a 2008 Honda Accord. But I went for lunch to a little town near me (where the Goodguys show is) and had lunch at my old friend Marshall's place. You couldn't have wiped the smile off my face the whole time. You see this young man was about 13, 25 years ago when he use to sweep the floor in my shop. He is a great human being, along with his wife and today was the opening day for their little cafe. It is a super awesome place with his wife making some great stuff. So happy for them, they were very busy today with all the friends and family coming by. He looked a little overwhelmed.

Brian
Yesterday 02:27 PM
Project89
Quote:
Originally Posted by MARTINSR View Post
Holy crap! Sorry to hear it, damn.

Brian
lol its ok, chicks dig scars lmfao
Yesterday 01:30 PM
496CHEVY3100
Quote:
Originally Posted by John long View Post
I have had my H-D Electraglide Ultra Classic on Craigslist for a couple of weeks and not a single call. The market is sure not what it used to be.

On a happier note, I trimmed and fitted my quarter panel today. Kind of good to have something worth posting.

John



What are the 4 faces,
Yesterday 01:24 PM
MARTINSR
Quote:
Originally Posted by 496CHEVY3100 View Post
wrong post
HUH?

Brian
Yesterday 01:22 PM
496CHEVY3100
Quote:
Originally Posted by MARTINSR View Post
John, you ROCK! Thanks so much for showing us how you are doing that, friggin magic is what you are doing.

Brian
wrong post
Yesterday 01:15 PM
MARTINSR
Quote:
Originally Posted by Project89 View Post
i posted it back on the last page but
i crashed that xr250r i painted on sunday , my foot got tangled up in the bike during the wreck so me left ankle is all messe dup and i hit directly on my shoulder breaking the collar bone and sperating it before my head hit the ground cracking my helmet and giving me a nasty concussion.

other then that and some nasty brusing and road rash im in pretty good shape.

i was pushing myself and the bike well past my limits and well ^^ thats the result. i was riding by myself so i didnt relize just how hard i was pushing until after i wrecked

edit

nobody ever got faster or better by not pushing the limits lol
Holy crap! Sorry to hear it, damn.

Brian
Yesterday 12:03 PM
Project89
Quote:
Originally Posted by BuzzLOL View Post
. Bike looks great... but I assume that's the 'before' picture... what kind of paint on engine? Did it stay on?
the paint i still in great shape except for a nice scatch and chip on the front fairing which i have a small sticker to place over it to hide it.

the paint on the engine is high temp bbq paint m it rubbed off in 2places were my leg was against the motor when riding before i got the engine hot enough to cure it , but i can touch it up no problem. just need to let the bike sit and idle before i ride it again so it cures so i dont rub the paint off this time

edit u may have to exscuse some of my posts and spelling for the time being , theese pain killers they gave me do a number on me , dont like it at all
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.