Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics> Cooling fan
User Name
Password
lost password?   |   register now

Thread: Cooling fan Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-21-2012 12:43 PM
TDoylecinci
cooling fan switch

Thanks for the info. I read where the knock sensor was in the block but didn't see it. The fan switch makes sense as the fan sisn't come on until a/c was switched on. Thanks for the info
10-21-2012 12:39 PM
malc Itīs the cooling fan temp switch that is located between 6 & 8 plugs.
Knock sensor is low on the block above the pan rail.
10-21-2012 12:17 PM
TDoylecinci
Cooling fan

Adjusted valves on 1990 Camaro 305 and what I think is knock sensor got broken. It's located in right head between plugs #6 & 8. The fan didn't come on when temp got high and I took it to a friend that does some work on it. He said it's the temp sensor but I don't know. If a/c is switched on the fan comes on, so it worlks. Wondering if the sensor broken is part of problem w/fan not turning on with high temp. Please help diagnose....

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.