Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> 283 wont idle
User Name
Password
lost password?   |   register now

Thread: 283 wont idle Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-31-2012 04:16 PM
cdminter59
283 wont idle

Is the vacuum line for the PVC valve plugged into the carburetor? Is the vacuum line from the brake booster plugged into the back of the carburetor? Get a can of carburetor cleaner and spray along the intake where it bolts to the heads. Also spray in front and back of the intake along the china walls. Check the carburetor base gasket too. If the idle speeds up more you have leaking intake gaskets. Set the timing to 12* BTDC starting out.
10-31-2012 02:00 PM
vinniekq2 what tech said. make sure the timing is set and idle screw is advanced.easier to turn down as you figure problems than try to keep running.
10-31-2012 12:08 PM
techinspector1
Quote:
Originally Posted by jtheshowstoppper View Post
my dad put his 283 back in his c10 engine was reuilt to stock except he switched the manifold on it and got rid of the filler tube and plugged rear hole in back of block he added a 4barrel edelbrock carb it turns on first crank but wont idle no matter what we try could it be because the filler tube is gone and the rear hole is plugged?
I have to assume that you have provided some other means of evacuating the crankcase pressure, but that's not the problem right now. It won't idle because there is a giant vacuum leak somewhere. Been there, done that.
10-31-2012 11:45 AM
jtheshowstoppper
283 wont idle

my dad put his 283 back in his c10 engine was reuilt to stock except he switched the manifold on it and got rid of the filler tube and plugged rear hole in back of block he added a 4barrel edelbrock carb it turns on first crank but wont idle no matter what we try could it be because the filler tube is gone and the rear hole is plugged?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.