Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics> cam bearing issues LS 6.0L blocks
User Name
Password
lost password?   |   register now

Thread: cam bearing issues LS 6.0L blocks Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-26-2012 01:31 PM
67-4-fun i was talking to my cousin yesturday during our family christmas, he knows a few mechanics working for local chevy dealers in indy, they told him they have had several 6.0L engines with cam bearing issuse, having cam bearing replace. I guess from talking to my cousin, the 6.0l must have oiling issuses to the cam bearings, causing cam bearing failure.. So that may go along with the what the previous post said about oil pumps.. im was just curious if it was a common problem with the 6.0L.. the 5.3L i guess dont have this issue.. but anyway you look at it a bad oil pump regardless will cause bearing failure
12-26-2012 11:37 AM
mbossio Haven't heard about that one but there are lots of oil pump issues, specifically with the preasure relief valve sticking open toasting the motor. You can read a lot about it on LS1GTO.com
12-26-2012 09:56 AM
BOBCRMAN@aol.com Only problems I have seen is a cracking problem with some casting numbers, never had a cam bearing problem.
12-25-2012 09:00 PM
67-4-fun
cam bearing issues LS 6.0L blocks

for all you guys that are filimilar with the LS series engine. I was told today that there are cam bearing issues with the 6.0L blocks due to the oil sloshing around to much in the oil pump or something to that effect, causing cam bearing to go bad, anyone filmilare with the ls 6.0l blocks confirm this?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 03:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.