Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> Front Wheel Cylinders On a 67 Impala
User Name
Password
lost password?   |   register now

Thread: Front Wheel Cylinders On a 67 Impala Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-02-2013 07:51 PM
63BigBlockedMerc Thanks bro didn't even think about looking at his activity just sign up for this thing
01-02-2013 07:12 PM
RWENUTS You might not get an answer 63. He was last on here in june of 2010.
01-02-2013 04:13 PM
63BigBlockedMerc How did you unscrew that pin bud ? I have a 63 mercury montery and it looks like the exact same set up. Thanks for the help
08-25-2009 12:01 PM
BowTiePride As far as I've ever noticed the rears were always held in by the two bolt setup, but he front, you had to take off the 15/16" pin at the top to the backing plate, and the cyl popped right out. Had to take off the brake line at the frame so the flex hose could come through the backing plate so I could stick it in a bench vise and use some leverage to get off the brake hose (not enough room in behind while attached, and stuck on VERY good). Next up:THM350 swap and toss the powerglide
08-25-2009 07:18 AM
cobalt327 I wonder when the change to using the two, 1/4" bolts to retain the slave started? I'd have bet the farm that my '68 Le Mans had the 2 bolt arrangement, but it's been a long time ago since I did those brakes, and I don't recall doing any others (except changing the entire front end to disc from drums).
08-25-2009 06:21 AM
T-bucket23 I can honestly say I dont ever REMEMBER doing one of those. Of course latly I can remember much it seems
Glad you got it figured out.
08-25-2009 12:25 AM
BowTiePride Thanks a bunch guys They are definately a pin in the rear to do!!!! But she's all done and my 67 Impala is now on the road
08-21-2009 08:15 AM
joe_padavano
Quote:
Originally Posted by T-bucket23
Didnet think it went back that far but some cylinders had a clip arrangement on the back and they were a real pain.
The clips don't go that far back. Mainly they were used on the 78-88 A/G-body cars.

Quote:
I dont think I have ever attempted to remove the top stud you are referring to for cylinder removal. If you look at teh new cylinders, it should be obvious how they mount
Yeah, I'd say it's pretty obvious that you need to unscrew that pin:

08-20-2009 06:41 PM
T-bucket23 Didnet think it went back that far but some cylinders had a clip arrangement on the back and they were a real pain.
I dont think I have ever attempted to remove the top stud you are referring to for cylinder removal. If you look at teh new cylinders, it should be obvious how they mount
08-20-2009 10:20 AM
BowTiePride It's a 67 Impala 4dr, 4 corner drum, with mechanical braking, by the way
08-20-2009 10:18 AM
BowTiePride
Front Wheel Cylinders On a 67 Impala

Hey everyone, the only reason why my car didn't pass an inspection (i've been dying to get my baby on the road and ditch my tired rusty 4runner for a long time now) was the wheel cylinders. Got the back ones done (major pain), and parts finally came in for the front ones. I noticed that they do not have the two bolts in the back holding them in, and no rivets. What it looks like, is the top pin/bolt that the C-shape on the shoes rest on (Sorry, not too up-to-date on brake terms ), is what holds it in, as the cylinder extends all the way up and behind in between the backing plate (again, sorry if incorrect) and the nut on the pin. What all do I have to do to get that bolt/pin off? Any tips or tricks? Thanks for the help,
Jake E

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.