Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Garage - Tools> Sandblaster help
User Name
Password
lost password?   |   register now

Thread: Sandblaster help Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-06-2013 01:36 PM
crownver The filter that came with the cabinet is #33 to #37. King Canada is like a Harbor Freight in the States I think. Their stuff is pretty cheaply built but is okay for light use. At the price they want for a filter I think I'll be looking for something else, like maybe a lawnmower filter or something, when I need one.
01-06-2013 08:22 AM
DanielC You need to keep the blasting media dry or it clumps up, and will not flow.
If the sand feed is suction only, if you block the nozzle of the gun, it blows air backwards through the sand feed hose, and removes the clog, but if the sand has moisture, it quickly clog again.
Sometimes suction feed needs a little adjustment on the amount of sand being fed in to the feed hose. You need air to flow in to the hose, to bring sand with it. Kind of like a carburetor, not too rich, or too lean.

You need to vent the cabinet. The gloves should inflate a little, but not go out fully stiff. You need some air flow through the cabinet, to clear the air, so you can see what is blasted, and areas missed. but too much air flow will suck good blasting media out of the cabinet.

Probably should wear a dust mask, to reduce the amount of dust you inhale.
01-06-2013 07:56 AM
Ben78 I couldn't think of what it was called, a line dryer is what I meant for the gun. Do I need one of these if I'm using glass bead? The gun seems to work well in the beginning, but then it doesn't work as well after a few mins. Does that have anything to do with the pressure or is the glass bead getting moist? Thanks guys
01-05-2013 08:45 PM
jsaw Sound like you need a hole to let air in to replace the air that you are pulling out with the vacuum
01-05-2013 02:33 PM
crownver Filter is a small paper unit. Not sure where to get one but I'm going to start looking. It's just to let air in/out without carrying dust/sand with it. Not sure what you mean by a filter on the gun. Air just needs to be dry.
01-05-2013 01:40 PM
Ben78 Cool, I can turn the vacuum down lower. What kind of filter do you have on you 1" hole? Ill make the hole bigger also. Do you think i need an air filter for the gun? Thanks
01-05-2013 01:17 PM
crownver You shouldn't need a ton of vacuum power. All your doing is getting rid of the dust in an enclosed cabinet. What I did was mount a small pipe on the cabinet and just slip a shop vac over the pipe. It's sucking air around the pipe but gives enough vacuum to get rid of the dust. My cabinet also has a hole in the opposite end about 1" with a filter on it.
01-05-2013 12:47 PM
Ben78
Sandblaster help

Hi guys,

I'm hoping somebody can help me out here. I built a Sandblaster out of ply and have 100 lbs of glass bead in it. I'm using a Campbell hausfeld $15 Sandblaster I got off amazon. The cabinet is siliconed and pretty airtight. We've got a huge air compressor, so I don't have any problem with pressure. I cut a hole for my festool vacuum, but when I turn it on, the gloves go completely rigid and straight out. I drilled a small 3/8" hole on the opposite side of the vacuum to help relieve some of the pressure. I have no air filter on the gun, do I need one? When I use the blaster, the pressure is so strong, it's difficult to move my arms. Any thoughts? Thanks in advance

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.