Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Spark plug misfiring
User Name
Password
lost password?   |   register now

Thread: Spark plug misfiring Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-31-2013 04:08 PM
T-bucket23 What brand plugs. If they are Bosch, throw them away and get some AC's.
Was it misfiring before you changes them?
01-31-2013 10:49 AM
killeratrod timing does not change from changing your plugs. I asked what type of plugs to see if they were cheepos. like cdminter59 says check the plugs. Also are you sure you have the wires correct and on tight.
01-31-2013 10:44 AM
cdminter59
Spark plug misfiring

What engine do you have 3.9 or 3.5? You may have gotten a bad spark plug. Pull one wire off at a time to see if there is any change in the way the engine idles. If you pull the wire off the plug that is bad there will be no change in the way the engine runs.
01-31-2013 10:09 AM
dbezzel I've checked them with a plug tester and everything is fine. I was thinking, could the coil be weak or is it the timing
01-30-2013 09:25 PM
killeratrod what plugs did you buy, also you may have broken a wire !!









1
01-30-2013 08:52 PM
DoubleVision Did you drop any?
01-30-2013 08:19 PM
dbezzel
Spark plug misfiring

I have an 08 chevy impala, i changed my spark plugs and now its misfiring. Can anyone let me know why its doing that, i had oldschool cars changed those plugs and they run like new, can anyone tell me whats wrong?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 08:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.