Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> 1991 Acura Legend rusty looking trans oil
User Name
Password
lost password?   |   register now

Thread: 1991 Acura Legend rusty looking trans oil Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-11-2013 06:48 PM
apemanbrownhole i didnt pay much 700 bucks...its just a starter car to practice in and get my license but if i can make better for a resale then by all means i want to..all your replys have been helpful except scrapin it. ill deffinatly be making it better for resale though
02-11-2013 05:02 PM
Mad Tiki Customs I hope for your sake you didnt pay much for your Acura. Between the 1/4 and the trans, your looking at a pretty big amount of work there. If your experiencing a banging or jumping when putting it into gear, it could be your engine, and or trans mounts. Honestly, not to burst your bubble, but that car should be just a parts car at most. I would part it and move on to something better of an investment.
02-11-2013 04:35 PM
rick 427 If that model has a trans pan,you might want to drop it ,and get a better idea of whats going on.
02-11-2013 03:54 PM
ssimpala Check your radiator. The internal cooler may have gone bad and you're mixing water and trans fluid.
02-11-2013 03:36 PM
snakebit68
Trans fluid

First of all, check the fluid while the car is running. You may still be low on fluid. On a more serious note, you should be concerned with where the fluid went to begin with. I suspect a leak somewhere. Once you can remedy the leak I would suggest changeing the trans pan gasket and filter. Dont get me wrong, there could certainly be more serious issues with your trans that may only be addressed by rebuilding. Hope this helps
02-11-2013 03:02 PM
apemanbrownhole
1991 Acura Legend rusty looking trans oil

Ok so i have a 91 acura legend i just bought.

i checked the transmission levels and it wasnt reading so i put a quart of transmission fluid in it. now when i read the levels iits a rust lookin color on the stick. also when i put it in reverse or anything it kinda kicks and when i drive it and it shifts it jumps forward and the engine makes a whining noise like its winding up..is this bad please lend any advice so i can fix it before it gets worse

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.