Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Body - Exterior> Urgent paint Help
User Name
Password
lost password?   |   register now

Thread: Urgent paint Help Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-06-2004 07:26 PM
crazy larry did you do a thorough de-greasing before you shot your paint?

what kind of paint are you using?

you may be right on the lack of primer thought......
03-06-2004 09:59 AM
70chevy
Urgent paint Help

I am having problems with my paint. I am doing the interior, i had or thought i had finished the entire rear of my cab. I did not strip the paint to bare metal the paint was not chipping or cracking it really was in great shape. All i did was take off the clear coat and with a 320 grit roughen up the paint a little so it had a good bonding surface. There were also small little flecks of probally sand. When i took those down with the 320 i almost always ended up with a little bare metal. I think i know where i messed up. (not priming) Maybe someone can give me a diagnosis.... There are several small about the size of a toothpicks middle little spots were my paint has just flaked off. Weird things is there isnt bare metal where these are popping out. It is the original primer. There are three layers to the original stuff. THere is brown paint then an orange primer then Green Paint. The brown may also be primer i cant really tell. Can Anyone tell me what is wrong and what i might do to fix the problem. I was planning to sand the spots down and prime them, and then repaint. Good idea? Bad Idea? Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 04:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.