Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> Major transmission leak....HELP!
User Name
Password
lost password?   |   register now

Thread: Major transmission leak....HELP! Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-07-2004 05:04 AM
TurboS10
Quote:
Originally posted by BstMech
You mean the vent tube is on the left?

Now why didn't you look a little harder the first time instead of thinking the worst? You had us all worried there for a minute!

Oh well, it's not like I never changed a pan gasket only to find out it was the kickdown cable leaking......

We'll be expecting an update on your next flight too! Maybe a nice couple of pics of some serious damage next time, huh?
Sorry for the worry

When I could not find anything visibly wrong, I just thought the worst. I will remember next time this happens. I was looking at it on the side of the road laying in a puddle of oil when I first made the post. I was frustrated to say the least.

Chris
05-06-2004 08:59 PM
BstMech You mean the vent tube is on the left?

Now why didn't you look a little harder the first time instead of thinking the worst? You had us all worried there for a minute!

Oh well, it's not like I never changed a pan gasket only to find out it was the kickdown cable leaking......

We'll be expecting an update on your next flight too! Maybe a nice couple of pics of some serious damage next time, huh?
05-06-2004 06:58 PM
TurboS10 It is a manual valve body. There was an old cable end in there, but I think the plastic flange that holds it in must have gotten broken on installation or something because it is gone now.

Chris
05-06-2004 05:51 PM
darom Chris, I am glad you found your leak and it is a cheap fix as well.

Are you using a manual body to switch gears or using an electrical signal to downshift? Why did you leave the kick-down cable out?

Denis
05-06-2004 05:18 PM
camaroman7d Right on easy and cheap fix. I have shattered a th 350 case and was still able to drive it, so don't thin a broken case will stop you in your tracks but, for it to leak as much as you mentioned ot would have to be a major hole.

If the th350 works for you stick with it. I just don't know anyone that can make them live reliably behind big power (500 or more HP) maybe in a light car. The sprags just can't take the abuse.

Royce
05-06-2004 03:26 PM
TurboS10 Well, Darom hit the nail on the head. I just went out and crawled under the truck and checked the kickdown plug......It was not there. The damed cable end that was in the hole fell out. Should be making boost again tomorrow morning

Thanks Guys,

Chris
05-06-2004 12:24 PM
TurboS10 Royce, agreed on vent tube. The dipstick tube is still in place. It is a Lokar and is a perfect fit with double orings. After some thought, I dont see how the trans would still operate if the case cracked because it seems it would have all kinds of internal pressure leaks. I did pull the truck on the trailer under its own power. The leak is definately not related to pressure as well. We jacked up the passenger side and it quit leaking. Let it down level and it pours out untill oil level goes down.

It is funny you have had better luck with TH350's. I went through a couple TH400 rebuilds and switched to a TH350 on my 57 with no problems. Of course I think that was a pump failure problem from increased pressure. I am not using a brake so I am hoping the TH350 will live until I go with a Powerglide. The friend of mine who built this transmission has run TH350's behind 700+HP big blocks. Of course, like you say, it takes a set of clutches once in a while. High gear being the main problem from my understanding.

Later,

Chris
05-06-2004 12:00 PM
camaroman7d The vent tube is on the drives side and I doubt that is your problem. Are you sure you din't blow the dipstick tube out? If not, there is noting else on the side that would cause this unless you broke the tranny case or the pan.

Chris you should really look into a th400 for the kind of power you are making. You are going to be changing th350's like you change shoes. After breaking a couple of pro built th350's with only ~500HP, I built my own th400 and it is holding up well to a lot more power.

Royce
05-06-2004 11:27 AM
TurboS10 Hmmm.....have not looked at that. It does not have a kick down cable at all. The guy who built my transmission plugged the holes. It has not leaked until now, but I guess it is a possibility that a plug came loose. Thanks for the tip, I will give it a look when I get under there.

Chris
05-06-2004 09:23 AM
darom Have you checked your kick-down cable plug/mount? My friend's Camaro tranny leaked bad, we jacked up the car and saw that he had snapped the kick-down plastic insert on the tranny by twisting the cable (he tried to route it with the cable attached to the tranny case).

Regards,
Denis
05-06-2004 06:24 AM
TurboS10 I think you are right. But this leak is at the pan level I think. The oil runs out about as quick as I pour it in and there is not oil up high. It is all at the pan rail. I have had vent tubes blow oil before, but never anything like the quantity that this is.

Thanks,

Chris
05-05-2004 09:50 PM
BstMech I believe the little vent tube runs toward the pasenger side from up top.
05-05-2004 09:41 PM
TurboS10
Major transmission leak....HELP!

Hey guys,

I went out for a drive in the S-10 today and found another problem. After beating on it a little the transmission begain to hemorrage oil everywhere. It was like taking out a drain plug. From what I can tell there is a bad leak in the front of the transmission in the pan area. After some work, I found that when I pour more oil in it runs right out without the engine running. It looks to be running out of the pan gasket area, but the gasket is in place and the bolts are tight. I just want to know if any of you know of a plug or something that could come out on the passenger side of a TH350. It is possible that the oil is coming from above the pan in the dipstick area, but it is not coming from the dipstick and I can not see anything else that would leak. My fear is a case crack since I can not see anything wrong.

I will not have a chance to get it apart until Friday and I am pretty sick about it so I just thought I would see if any of you had any ideas.

Thanks,

Chris

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.