Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> HELP...'85 Seville brake question
User Name
Password
lost password?   |   register now

Thread: HELP...'85 Seville brake question Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-21-2004 02:27 AM
Kevin45
HELP...'85 Seville brake question

I need some big help here. On my fathers '85 Caddy Seville...when he pulls out of the garage in the mornings the brake light on the dash will be off. When he drops it into drive and starts moving the brake light on the dash will start to come on but will remain dim. One person told him he needed new brakes. So he had new pads put on. Then he was told he needed a new brake vacuum canister and it was going to run around a thou. because it had a small leak. I checked the canister (behind the master cylinder) and there was no leak. You can hear a small leak somewhere under the dash but I feel that it is coming from a heater control. Also the emergency brake was depressed and released a few times to no avail. He has excellent brakes. I told him if the vacuum was leaking he would have intermitten power / no power brakes and the light would probably not come on. I have looked over everything I know possible and have done a few searches without any results so I thought I would ask here. If anyone has any ideas I would appreciate it. TIA.

Kevin

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 12:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.