Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> 65 Impala Transmission Question
User Name
Password
lost password?   |   register now

Thread: 65 Impala Transmission Question Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-13-2005 07:14 PM
Crosley One item about the use of a late design filter in the early trannys..... your valve body ( if it is early unit) will NOT have a threaded hole for the late design filter retaining bolt.

The late design filter uses a shouldered bolt to hold the filter to the valve body...... although the filter will move a round a bit.

Second........ the late design filter uses a separate pick up tube with O-ring that goes between the case and the flat filter. This tube would NOT be in the gasket / filter kit you bought.


You may have to find a local tranny shop or parts supplier to purchase the early design filter for your t-400
07-13-2005 04:47 PM
Deuce The early 400's have a different filter than the later ones...1966 or 1967 was the changeover year IF I remember correctly.

The kit you bought came with the later one......
Your 400 can be converted but WHY ? ?

You just need a early filter.

DEUCE.......
07-13-2005 03:07 PM
EazyDuzIt102 On the first Picture I uploaded is what I think might be the filter that I pulled out of my transmission.The 2nd picture is what came with gasket I bought.The gasket fits the pan perfect.Is the thing in the first picture a filter?Any help would be appreciated.Thanks.
07-13-2005 01:28 PM
EazyDuzIt102
65 Impala Transmission Question

I got a 65 Impala with a 400 Hydramatic transmission.I needed to replace the gasket on the pan.I bought the kit that comes with the Gasket and the transmission filter.When I took the pan off today I was looking in there and cannot find where the filter goes.Do I have to take something else apart after I get the pan off?Also,I was wondering what was the best way to install the gasket for the transmission pan?I just want to make sure I install it right.Thanks alot,

Eazy

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 11:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.