Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> small block engine rebuild
User Name
Password
lost password?   |   register now

Thread: small block engine rebuild Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-06-2006 05:08 PM
poncho62 moving it there.
04-06-2006 04:14 PM
Henry Highrise Welcome to Hotrodders....this forum is for introductions not questions...your question needs to be in the Engine forum.
04-06-2006 03:54 PM
74camaro
small block engine rebuild

I had a 350 chevy rebuilt last fall. The car sat for most of the winter except for occasional starts. After one start and 10 min of idle a loud intermittant bang could be heard coming from the lower half of the motor. The 2 engine builders tore down the motor and found no damage internally from the engine. it wasn't a stuck lifter, lifter loosing prime, connecting rod cap loose etc. the sound wasn't a tick but actually more of someone hitting the inside of the block. the 2 guys have over forty years experience between them and have no idea what causes the noise that they also heard themselves, again the engine shows no sign of any damage or parts damage at all. hopefully i gave enough information on this. Two cam lobes where flat so a new cam and lifters are going in. again i'm real curious as to what would cause this sound no one seems to know. Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 07:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.