Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> 700R4 tranny shifting to fast at low RPM
User Name
Password
lost password?   |   register now

Thread: 700R4 tranny shifting to fast at low RPM Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-27-2006 08:31 AM
454C10 Need to get a shift govern kit. The govern is in under the 3" round dome looking thing on the side of the transmission. The cover just pry's off and you can pull out the governor. The govern has weights on it (like a distributor advance) and the heavier the weights the sooner it shifts. There are some welded weights on the spinner that you can cut off. The lighter the weights, the later it shifts. There is a govern kit available that has different weights and springs.
05-18-2006 10:00 PM
Crosley
Quote:
Originally Posted by Danscam
Installed a 700 r4 tranny and it seems like its shifting to fast when in drive.when i manually shift ,it works great. Can somebody help me out with this problem. maybe something needs ajusted,replaced etc.

is the tranny TV cable setup correctly and has full pull of the TV cable at wide open throttle?
05-18-2006 09:53 PM
Danscam
700R4 tranny shifting to fast at low RPM

Installed a 700 r4 tranny and it seems like its shifting to fast when in drive.when i manually shift ,it works great. Can somebody help me out with this problem. maybe something needs ajusted,replaced etc.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 10:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.