Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> speedometer
User Name
Password
lost password?   |   register now

Thread: speedometer Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-14-2006 03:23 PM
88chevy i replaced it cuz the stock speedometer was like magnetic or something and the gear for the speedometer is plastic on the tranny i just put in, and i put in a speedometer that is driven by a gear and has the same connection from the truck to the speedometer
06-14-2006 09:18 AM
Jmark Need to clarify something. Does the trans have an electrical connection? or does the CAR harness have an electrical connection? Makes a difference what the fix is.

Mark
06-14-2006 06:45 AM
tnsmith10 check the fuses under the dash 1st, if all is ok, then check the wires that go to the v.s.s. (vehicle speed sensor). i have seen the wires melted together b4... local dealer should carry the pigtail in stock...
theres more that it could be, but that would be a good place to start.
and b4 i forget, why did u replace it? was the speedo already not working? was it leaking? more info please.
06-13-2006 10:50 PM
88chevy
speedometer

i just installed a speedometer on my tranny its a 700 form a 1988 chevy and it wont work the speedometer has an electrical connection can neone help!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.