Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> siezed oil pump
User Name
Password
lost password?   |   register now

Thread: siezed oil pump Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-17-2008 07:46 PM
nosman
siezed oil pump

I just talked to a real motor builder and he said he ran into this problem before. And said the SVO pump shaft Iam using is to long He said they make 3 diff ones. if it does not have 1/4 to 3/8 up and down play in it when the pump and dis installed. It will sieze up a pump fast and mine had no play in it. I hope this will fix the problem. Thanks for everybody help.
07-17-2008 06:15 PM
woodz428 Since they live in oil, it's unusual for one to "lock-up". As others have pointed out you have ingested something. I recently pulled a pan off an early Bronco that had that happen...twisted the drive hex like a piece of licorice. he had just had a new pump installed a few months earlier by another shop and when we removed it it was jammed solid. I pulled it down and discovered that the original pump installer had been careless when scraping the old gasket( between the pick-tube and pump) and had lost a small piece of the gasket into pick-up tube( most likely). After a few months operation it had finally been drawn into the pump and was smashed between the rotor and it's outer impeller. After knocking the pump apart and removing the minute gasket piece the pump rotates freely. I won't use the pump, but always like to understand what generates a failure. They are very tight tolerance and it doesn't take much to lock them.
07-17-2008 05:48 PM
bates_k Read this...

http://www.460ford.com/viewtopic.php?t=20615

And become enlightened...

K
07-17-2008 05:05 PM
61bone That pump should turn fairly easily. Do you have a intake screen on it? Just asking- If it only turns part way, it has something in it or has a scored housing. Either way, it time to rethink using that pump.
07-17-2008 01:56 PM
nosman
siezed oil pump

Iam using a flat tappet cam Comp Cam with a Ford motorsport chain & gear
07-17-2008 01:53 PM
nosman
siezed oil pump

Ok thanks for the Info. I will take apart the pump an check it. Could be they did not get the dirt out last time.
07-17-2008 01:35 PM
gregb Take the pump apart, you should be able to see what is causing it to lock up. The gear pieces are probably in the pump on the current one. What kind of cam are you using, roller or flat tappet? Many roller cams require a special gear on the distributor. If everything checks out you have some dirt or debris somewhere. Any metal in the pan besides the gear? What was found in the pan the first time, maybe they didn't clean it well enough before it went back together.
07-17-2008 01:23 PM
nosman
siezed oil pump

The frist time it went I had the whole motor gone thru again. with the pump being out it only turns 9 oclock to 3 oclock then back. And did not take the pin out this time it took the teeth from the gear of dis. It does have a HD shaft. Parts of the gear is in the pan.
07-17-2008 01:03 PM
gregb The only reason for them to seize would be that they got dirt or something metal in them. Are you running one of those HD oil pump shafts or the stock Ford shaft? When you say took the gear off did it shred or break the roll pin? Any debris in the pan or filter? If it just broke the roll pin and the gear came off you should have replaced that pin after the first failure. DOes the oil pump turn at all when it's out of the engine?
07-17-2008 12:44 PM
nosman
siezed oil pump

Iam having oil pump problems I have siezed two HV meiling pumps motor is new built 351 windsor alum heads fox body oil pan all MSD setup frist pump took the oil pump shaft this one took the gear off the distributor has 50-60 psi thru out rpm range any help would be great. Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.