Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> 74 chevelle 454 overheating
User Name
Password
lost password?   |   register now

Thread: 74 chevelle 454 overheating Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-18-2008 03:52 PM
oldbogie
Quote:
Originally Posted by MUR317
Thanks Guys, I Have Already Changed The Thermostat 4 Times 160-180-190-and Then A 180 Again.my Bottom Rad Hose Is New And It Does Have The Spring In It.so I Will Try A New Rad. And Put The Spacers In The Hood To See If That Works Thanks Again.


Mur317

I Will Let U Guys Know How I Make Out
Typical of insufficient radiator capacity. Either the radiator is too small to cool the amount of heat being brought to it, or it's becoming internally plugged with debris collecting in the tubes.

Other issues where an automatic is connected to the oil cooler is a high stall converter and or internal band/clutch slippage is building heat in the oil. This gets dumped in the radiator's coolant adding to what it has to get rid of. Engine timing and mixture ratios can also contribute to coolant heat load. So does air conditioning, when it's used it takes considerable power off the engine that's made up for with more throttle and the cabin heat is usually disposed of in front of the radiator adding temperature to the air entering the radiator. So the radiator gets a double whammy out of this deal.

Thermostat, unless failing to remain open, has no effect on this problem. If you use a 160 stat instead of a 200 all you'll see is that you get another 5 minutes before the problem shows on the gauge, BFD.

A 454 connected to a TH350 and a 10 bolt rear is probably not a factory installation, so what is the history of this thing?

Bogie
09-18-2008 10:47 AM
MUR317
74 Chevelle Overheating

Thanks Guys, I Have Already Changed The Thermostat 4 Times 160-180-190-and Then A 180 Again.my Bottom Rad Hose Is New And It Does Have The Spring In It.so I Will Try A New Rad. And Put The Spacers In The Hood To See If That Works Thanks Again.


Mur317

I Will Let U Guys Know How I Make Out
09-17-2008 08:13 PM
DoubleVision Even so this sounds so simple, change the thermostat. Couple of years back I had the same issue and couldn`t figure out why it ran warm on the interstate but not in stop and go traffic. I finally thought "I wonder if the thermostat is staying open" I removed it, put it in a pot of boiling water with a temp gauge and found it stayed open after it got up to opening temp, when the water in the pot finally cooled below a 100 degrees, it would close.
Since then I have found it`s hard to get a good thermostat, regardless of the name brand, every name brand I tried has failed on me so I kept buying stants until I got a good one.
09-17-2008 08:13 PM
75gmck25 I have similar problems with an SBC 350 in my '75 GMC, so I've been reading through various articles and troubleshooting guides.

Most troubleshooting guides says that high speed cooling problems are usually due to insufficient radiator capacity (either too small, or plugged up), or insufficient water flow. The guides also say that some type of air flow limitation is also a possible source, either due to air damming up in the engine compartment, or missing air dams/skirts that let air go around the radiator.

For your BBC, checking the lower hose and pump for proper operation, and then switching to a four row radiator is probably the logical first step, followed by a switch to a high flow water pump. The suggestion about removing the hood seal or propping it up at the back to allow more airflow is also a good idea, since its very cheap to try.

Bruce
09-17-2008 06:41 PM
babygene41042 I would say that you need at least a 4 core radiator.A 3 core is a little small for a big block.If you are making over 400 horse I would say that's your problem.
09-17-2008 02:26 PM
techinspector1 Running hot on the highway, but cool in traffic could be that the engine bay is restricting the egress of hot air at speed or cooling air is going around the radiator at speed due to the configuration of the frontal components on the car or the bottom radiator hose is collapsing due to lack of an internal spring to keep it round. It could be a myriad of goofy things too, like the water pump impeller spinning on the drive shaft at higher engine speeds.

I would first check the bottom radiator hose for a spring. Then I might make some spacers to space the rear of the hood up off the cowl by 1 1/2 to 2 inches and see what happens at speed. That will tell you if the air has been damming up in the engine bay. Take a look through this wiki article and see if anything jumps out at you, in addition to what I've said.
http://www.crankshaftcoalition.com/w...cooling_system
09-17-2008 02:07 PM
MUR317
74 chevelle 454 overheating

Hi, I Have 1974 Chevelle 454 Street And Strip 350 Turbo Trans 10 Bolt Posi Rear 3.73 Gears. I'm Having A Problem Running Hot.when I Am On The Highway The Car Runs About 230 Degrees And If I Am On The Street Stop And Go Traffic The Car Runs About 190 Degrees.and If I Am Sitting In Traffic The Car Stills Runs Around 190-.the Motor Has 180 Thermostat And A 3 Core Rad.i Could See If I Was Running 230 Degrees In Traffic. But I'm Not. Any Suggestions

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.