Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics> another chop job
User Name
Password
lost password?   |   register now

Thread: another chop job Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-22-2014 09:24 PM
knight hawk OK maybe tommorrow
11-22-2014 11:30 AM
deadbodyman Looks great man, how about a side view... I'm thinking about putting a visor on my 48
11-22-2014 11:16 AM
knight hawk I'm Back !!!!!!! here some pretty cool pictures of the car , with the recently added visor...........PS, the car still running great ! Aafter close to 5 years now, only repair has a dash bulb........and tires
04-30-2013 07:48 PM
knight hawk last picture didn't load, if not here is again OOP'S , I see it's in , was alittle too big
04-30-2013 07:33 PM
knight hawk Because this car (and others) sit so much, and usually takes some cranking to get the the fuel up, I decided to install an electric fuel pump near the tank, to 'prime ' the system. Now, all I do is hold the button in till the pump sound changes, (pressure build up ), and 2 pumps on the throttle, starts right up ! I mounted the pump direcrtly to the metal of the body, to make sure the 'sound' is heard inside the car. An ACC wire from the fuse panel, and button under the dash....
11-11-2012 10:35 AM
MARTINSR Sounds like a blast!

Brian
11-11-2012 10:29 AM
knight hawk a little up date here.... not been driving it it too much, except on Friday nites, a couple times a month. The 'used' engine is getting a littl louder lifter noise, but goes away after it gets hot. Got a click in the rear suspension when you step on it or hit the right bump. I think I'm getting some 'bump steer' effect at certain speed, but I think thats cause of the change in the trosion bars setting to raise the front height more. I beleive I was off on the ride height when I built the front frame and added the torsion bars set up . The car still draws a crowd ! Was at the Veterns Days Car show here testerday.... Get this ! At the car show, a man named Phil Spain came over, looked at the car, gave me lots of compliments on the car build, he said he was a friend of and worked with George Barris. Then later, I overheard him talking a another guy I knew, and knew he was for real !!! ....P S , I got a 2nd place trophy that day
10-08-2012 01:36 PM
MARTINSR You need to post in the Picture game thread, look at the last challenge, post #75.

http://www.hotrodders.com/forum/pict...ad-220831.html

Brian
10-07-2012 08:10 PM
knight hawk just a quick note here....kind of update. Haven't driven it alot, been getting it out every couple weeks, I've noticed a clunk some where when I step on it ,. It kinda sounds like the front/suspension. Also, the motor (318) has some lifter noise, but as this was a''junk'' engine that decided to run, and had some rust on the cam, so I'm lucky it's still running. Maybe, I'll get to rebuild it (here on this forum ) later,like maybe in the spring.......glad to see y'all still readin this....
06-12-2012 06:29 PM
deadbodyman beautiful, you could make post cards,just look at that big blue sky... I'm bringing my tent...
06-12-2012 06:16 PM
knighthawk pics of the 'new' place, house is pretty small, built around 1934, on three acres, very nice nieghbors, 2miles from a small town, were I meet 'the boys' for morning coffee, about 2 miles from the bigger town, with both a Lowes and a Home depot. Actually, a very popular 'retirement' area, as it also has a new hospital and a V A hospital, and a bout 1000 eating places !
06-12-2012 06:58 AM
deadbodyman Man, that sucks about the skirts.How do you like your new location so far,it looks great from here..Not many PITA neighbors..
06-11-2012 11:44 PM
knighthawk here's a picture of the dash...not too clear, but you can get a idea. So, next project was to tear down some old horse shelters, and 'rebuild' one, makes a pretty good 'car shelter' ! At least there are out of the hot sun.... PS, it was 100 degress today !!!!
06-10-2012 10:36 PM
knighthawk well, plans for the new shop are under way... won't start till July something, may start the ground leveling and cement before.... ABOUT TIME !!!! This car and another are sitting out in the sun ( 100 degrees here today !) . I put a sun deflector sheild in the windsheild.,, but cause the windsheild is so small ( due to the chop ) I needed to fold the sun sheild, ( made of bubble wrap ! ) in half. placed it on the dash, held up by the visors.....well, couple days later, I got in the car, for the local Friday nite cruise, took down the 'bubble wrap' , and revealed a nice imprint of the bubble wrap in the paint of the dash!, seems it softened the several coats of clear on the wood grain ! maybe I can get a picture tommorrow ...........another fine mess !!!
05-16-2012 11:57 PM
knighthawk I'm back ! finally got moved into my 'new' home, got everything moved from Kansas to Texas. Just got thr phone and internet connected today...I had the 'cars' hauled on a transport, thats the ONLY way to do it ! Just before the truck came, they told me that if my '48 was ''slammed'' , it wouldn't clear the ramps, so quickly, I had to relocate the shocks, luckily, there was some empty holes in the frame about 2'' lower. So, I took the skirts off, pulled the tires , moved the shocks put the wheels back on , drove the car out, to check the ride height............ yup ! forgot the skirts....drove right over them ! only bent the mounting tabs and the very ends. Could have been worse ! So, here, I been deiving it around some, still draws a crowd ! NOW, I need to build me a new shop, so I can get back to work..............
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 11:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.