Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> 81' Corvette Idling Problems
User Name
Password
lost password?   |   register now

Thread: 81' Corvette Idling Problems Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-03-2008 01:06 AM
carsavvycook I checked out a 1980 Corvette today, and the throttle was doing the same thing. Someone had backed the throttle stop screw all the way off, and it felt like the throttle plate was sticking in the bores. The mixture screws were adjusted almost all the way out to compensate for a decent idle.

At first I thought of weak throttle return springs, but after adjustments it came right back down to the proper idle speed.

This might be something else to check.
12-03-2008 12:36 AM
oldbogie
Quote:
Originally Posted by ckpena
Problem: As my 81' Corvette, warms up, the engine electric choke does not seem to drop the engine into normal idle. The problem is intermittent but happens more frequently.

Background: My 81' vette has the standard Chevy 350 with the "Quadrajet E4ME" Carburetor. The car has about 85K miles on it. The carburetor system has worked fine and I have had no need to ever remove it for service. The car is garaged and I do most of the work on car myself. My biggest problem is I don't drive it enough but it is well cared for. I have zero experience on carb issues and would appreciate help and/or direction.

Actions taken: I've confirmed that I'm getting 12.5 volts to the electronic choke. I've applied liberal amounts of carb cleaner to all exposed parts to ensure that dirt and gum are removed. Once the car reaches normal operating temp and the engine fails to fall below approximately 900-1100 rpm, I'll remove the carb air filter cover and observe that the forward barrel butter fly valves are not fully open. I place my thumb on the barrel operating linkage to push the valves open while, at the same time, goosing the engine. The barrels move a few degrees further to max open and the engine drops to a normal 600 rpm idle. Sometimes this corrects the problem and other times, it doesn't. As soon as I accelerate a bit. the barrels fail to fully open and the engine idle remains higher than normal.

I've read the service manual but this carb stuff gets complicated quick and I am hesitant to approach things and make it worse without direction. You folks are great and I thank you in advance for sharing your knowledge with me.

R/Chris
Sounds like wear in the throttle shaft or its bore that allows the shaft to twist enough to bind in the bores or lets the throttle blades rub on their bores to catch the throttle before it closes against the stop.

Bogie
12-01-2008 12:42 PM
ckpena
81' Corvette Idling Problems

Problem: As my 81' Corvette, warms up, the engine electric choke does not seem to drop the engine into normal idle. The problem is intermittent but happens more frequently.

Background: My 81' vette has the standard Chevy 350 with the "Quadrajet E4ME" Carburetor. The car has about 85K miles on it. The carburetor system has worked fine and I have had no need to ever remove it for service. The car is garaged and I do most of the work on car myself. My biggest problem is I don't drive it enough but it is well cared for. I have zero experience on carb issues and would appreciate help and/or direction.

Actions taken: I've confirmed that I'm getting 12.5 volts to the electronic choke. I've applied liberal amounts of carb cleaner to all exposed parts to ensure that dirt and gum are removed. Once the car reaches normal operating temp and the engine fails to fall below approximately 900-1100 rpm, I'll remove the carb air filter cover and observe that the forward barrel butter fly valves are not fully open. I place my thumb on the barrel operating linkage to push the valves open while, at the same time, goosing the engine. The barrels move a few degrees further to max open and the engine drops to a normal 600 rpm idle. Sometimes this corrects the problem and other times, it doesn't. As soon as I accelerate a bit. the barrels fail to fully open and the engine idle remains higher than normal.

I've read the service manual but this carb stuff gets complicated quick and I am hesitant to approach things and make it worse without direction. You folks are great and I thank you in advance for sharing your knowledge with me.

R/Chris

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 03:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.