Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> 81' Corvette Idling Problems
User Name
Password
lost password?   |   register now

Thread: 81' Corvette Idling Problems Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-07-2008 05:32 AM
ffas23 Replace your Choke Pull-Off. They go bad after some time. I have sold plenty over the years to repair garages. They are vacuum operated to pull the choke open as the engine heats up. Its my bet this is your problem.

Rick
12-06-2008 07:11 PM
justacertifiedtech The fact that the engine rpms drop when you apply pressure to the butterfly linkage indicates that there is no binding in the idle step linkages.

So as SFRY said you are probably going to need to replace your bi-metal choke. (relatively simple if it has screws holding it on).
Before removing it, mark what position it is set to this will be a good starting point for installation and adjustment. There should be a small notch or groove on top of the choke and reference marks on the body of the housing.

If you need any other assistance let us know.

GL,
Tech
12-05-2008 09:35 PM
sfrymoyer Does that carb have a bi-metal spring in the choke housing?
If it does, over time the metal spring weakens and doesn't completely open the choke. Check to see if there is a spring, if there is, replace it.
That's one of the easier things to check.
12-02-2008 10:49 AM
ckpena
81' Corvette Idling Problems

Problem: As my 81' Corvette, warms up, the engine electric choke does not seem to drop the engine into normal idle. The problem is intermittent but happens more frequently.

Background: My 81' vette has the standard Chevy 350 with the "Quadrajet E4ME" Carburetor. The car has about 85K miles on it. The carburetor system has worked fine and I have had no need to ever remove it for service. The car is garaged and I do most of the work on car myself. My biggest problem is I don't drive it enough but it is well cared for. I have zero experience on carb issues and would appreciate help and/or direction.

Actions taken: I've confirmed that I'm getting 12.5 volts to the electronic choke. I've applied liberal amounts of carb cleaner to all exposed parts to ensure that dirt and gum are removed. Once the car reaches normal operating temp and the engine fails to fall below approximately 900-1100 rpm, I'll remove the carb air filter cover and observe that the forward barrel butter fly valves are not fully open. I place my thumb on the barrel operating linkage to push the valves open while, at the same time, goosing the engine. The barrels move a few degrees further to max open and the engine drops to a normal 600 rpm idle. Sometimes this corrects the problem and other times, it doesn't. As soon as I accelerate a bit. the barrels fail to fully open and the engine idle remains higher than normal.

I've read the service manual but this carb stuff gets complicated quick and I am hesitant to approach things and make it worse without direction. You folks are great and I thank you in advance for sharing your knowledge with me.

R/Chris

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 08:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.