Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> GT350 with CFI stalls
User Name
Password
lost password?   |   register now

Thread: GT350 with CFI stalls Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-15-2012 12:33 PM
Bubblehead
84 GT350 with CFI stalls

I still trying to fix my problem. Always starts easy when cold but has problems after a short warm up of 5 miles or so.... I just put on a new fuel pump and fuel filter but it still stalls when I slow down. Has no effect on highway speeds, only when I slow or stop. It dies; then after 5 minutes or less, it starts right back up and away I go until my next stop or slow for turns. Any ideas at all what I should be looking at???
12-09-2008 12:12 PM
techinspector1 I've found in the past that it's money well spent to purchase the factory service manual(s) for the car I'm working on. This looks to be a good set of manuals and they're a steal at $40. You could email the seller and ask if CFI diagnosis is covered to make sure before you purchase them....
http://cgi.ebay.com/ebaymotors/1984-...RCHQ3aUSQ3a102
12-09-2008 07:08 AM
Bubblehead
GT350 with CFI stalls

I have a 84 Mustang GT 350 20th anniversary model with CFI and when I slow down to turn or stop, it sometimes dies. It starts right back up, but it does die. I have done a complete tune up and replaced everything that should fix it, but it persists to do this. Also, at highway speed I think I feel it "surging" sometimes. I think this is the only car that Ford put CFI on so it is hard to find anyone who knows anything about this set-up. Any suggestions?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.