Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Garage - Tools> century 160 welder control board trouble
User Name
Password
lost password?   |   register now

Thread: century 160 welder control board trouble Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-20-2012 07:25 PM
toddp442
WFW160 control Board

I know that this is a long shot but I was wondering if by chance ultrawide is 1: still a member of this forum 2: still has the same welder and finally if he or anyone would be willing to look up the ic number for the IC behind Q1, I believe it to be IC1 but not sure as no markings on board unless under the chip and the IC next to Q2 is marked IC4 and there are only 4 on the board but still only a guess, any help would be greatly appreciated, as a replacement board is going for more than $200.00 and I can repair this one for maybe $10

Thanks`
01-23-2009 11:20 AM
powerrodsmike I have a century 160, Model 117-037 and bought the whole control PC board from my local welding supply for 62.00.
Lincoln took over Century, but still services the Century welders and it took about 3 days to get it in after I ordered it.

I found that my pc board had a crack somewhere..and became intermittent.

Later, mikey
01-23-2009 09:41 AM
kruzr Thanks for info,I beleive these welders can be sensitive,no matter what brand .

I have one that there is power going thru it with the power switch off.
Cant get it to weld though.....
01-23-2009 09:07 AM
ulrtrawide Cole. thanks for the info. I will check as you described. The front was burned and number unreadable. I did finally get through to a sevice tech at
A & A hydralics and he gave me the number of the updated transisters for the board also supposed to be heavier duty.
Q1 is aTIP142 and Q2 is a TIP 147 They replace TIP102 and TIP 107. I ordered them from http://www.parts-express.com/. This information is for others that may have this same problem. Once again I thank you for taking time to answer my thread. This is a great site!
01-22-2009 02:12 PM
Cole Just an FYI.. I did electronic repair for 10 years (in IT Now) and the transistors will usually have the number stamped on the bottom of it when it's not on the top.
Just wipe away the white heatsink goop and it should be there!
01-21-2009 05:54 PM
ulrtrawide
century 160 welder control board trouble

I would like to get some info on the control board in a 160 amp century welder model 117-037 . I need the number on the center Q2 transister. It is the center one of three that are mounted on the black heat sinks. If any one has one of these welders and would be willing to pull the side panel off and check it would be a big help. I can't seem to get info over the net. they all want to sell a new one for around $200.00.Can't find schematic on the net. HELP!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 05:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.