Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Garage - Tools> help with porter cable air comp??
User Name
Password
lost password?   |   register now

Thread: help with porter cable air comp?? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-17-2009 11:56 AM
930dreamer http://www.ereplacementparts.com/search_result.php

Try this site, there's a type 0,1,2 for your model. Shawn
02-17-2009 10:36 AM
oldred If it is simple reed valves and if you can find the valves (Tractor Supply keeps some reed valves) then it should not be hard to fix. Be warned however these compressors are generally considered to be of the "throw-away" variety and if the valves are not one of the common types they may be hard to find, any parts for this thing may be hard to come by. First MAKE ABSOLUTELY SURE!!! there is no pressure left in the tank and then remove the head from the pump, the valves should be thin flat flaps looking kind of like a feeler gauge and should be simple to replace if you can find the new ones. Take the head off and let us know what you find, a pic might help.



Make SURE there is no pressure left in that tank before starting to work on this thing because even a small compressor like that can hurt you if you disassemble certain parts with pressure on them.
02-17-2009 10:04 AM
Robbie is this easy to fix??
02-17-2009 10:01 AM
oldred I agree most likely valves leaking or broken, really common problem.
02-17-2009 09:50 AM
302 Z28 Bad reed valves or piston rings.

Vince
02-17-2009 07:44 AM
Robbie
help with porter cable air comp??

I have a porter cable jetstream air comp, #C P F 4515
(4.5 hp 135 psi 15 gallon 120v 15 amp)
The problem im having is
It use to build up to 120psi before shutting off..but now it hardly builds up to 60 psi,and stays running untill i unplug it.It will build past 60psi if i let it run for a while,but even then it will only be around 65 psi.. I have checked for air leaks and cant find nothing leaking.any help would be great.
Robbie

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 05:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.