Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> 1994 Chevy k1500 tranny problems
User Name
Password
lost password?   |   register now

Thread: 1994 Chevy k1500 tranny problems Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-22-2009 10:35 AM
fast68 hows the fluid look and smell ?


if its anything besides nice red and doesnt smell like good trans fluid then its probably just old and tired and worn out.

doing burnouts and such isnt exactly a good way to keep a tranny alive, especially in stock from.
and the model trans you have, especially.

good luck!
03-22-2009 10:24 AM
Crosley
Quote:
Originally Posted by rebel till death
hi i got myself a 1994 chevy k1500 and repainted it. i backed it out of the garage no problem. then my friends and me decided it would b cool to see the new truck do a burnout,so i powerbraked it until there was nothing left of my tires. i went to back it up to put it in the other part of the garage and i had no reverse..forward works just fine though any ideas


Mileage on this transmission?

Any recent repair work or just re-paintin the body?

I need to know IF all 4 forward gears work...

With reverse gone , the drive shell may have broken off splines.. this will result in NO reverse , no 2nd gear and no over drive ( 4th )

03-22-2009 08:27 AM
rebel till death
1994 Chevy k1500 tranny problems

hi i got myself a 1994 chevy k1500 and repainted it. i backed it out of the garage no problem. then my friends and me decided it would b cool to see the new truck do a burnout,so i powerbraked it until there was nothing left of my tires. i went to back it up to put it in the other part of the garage and i had no reverse..forward works just fine though any ideas..i was just filling in some blanks i left out..there was no tranny wrk done to it just body. there is 185 thousnd on the drive train the fluids look and smell okay and when i was movin it around the other day it seemes like all fourward gears were fine even second and overdrive thats why i wanted some advice b4 i tore into it

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 08:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.