Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> Brakes
User Name
Password
lost password?   |   register now

Thread: Brakes Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-11-2010 08:53 PM
cobalt327
Quote:
Originally Posted by schovil69
I will look into all this. Thank you!
I should add, if the calipers are old, or the car has sat for an extended time, there's always the possibility the caliper pistons are sticking in their bores.

Also, if there's a lot of movement due to incorrectly adjusted wheel bearings or worn wheel bearings, the wheel can kock and will be hard to rotate.
04-11-2010 08:43 PM
schovil69 I will look into all this. Thank you!
04-11-2010 06:49 PM
cobalt327
Quote:
Originally Posted by schovil69
Thank you for your response!

While I neglected to mention the rubber brake lines, I had heard that they can cause this. I replaced them in 2001. That being said, I can see that they may have become defective, albeit unlikely.

I drive the car occasionally and everything is fine. It's just that I would think the front wheels would roll more freely.
Well, there shouldn't be any real brake drag, nor should there be any bearing drag that would prevent the wheels from turning w/o a lot of friction.

If you jack up one wheel, remove it and inspect the rotor for having overheated due to the pads rubbing. You can also pry the pads away from the rotor, replace the wheel and see if it improves.

While the wheel is up in the air, see if there's any slop in the wheel bearings, pop a bearing cap and remove the cotter pin, nut, washer and bearing and see if the outer bearing/race is discolored or pitted. See if there's sufficient bearing grease.
04-11-2010 05:40 PM
schovil69 Thank you for your response!

While I neglected to mention the rubber brake lines, I had heard that they can cause this. I replaced them in 2001. That being said, I can see that they may have become defective, albeit unlikely.

I drive the car occasionally and everything is fine. It's just that I would think the front wheels would roll more freely.
04-11-2010 01:33 PM
cobalt327 Your car came w/a distribution block that contains a brake warning switch that illuminates a dash light if there's a pressure differential between the sides of the system that would indicate a leak. There is no "proportioning" or "metering" functions to this distribution block- it just routes the fluid to where it needs to go.

Up by the master cylinder (MC) there should be a "hold off" valve that "that mounts on the stud of the MC on all factory 1967-70 disc brake cars. It is used in conjunction with the distribution block mounted on the frame, which is the same on factory disc and drum cars. This valve holds off the front brakes to give time for the rears to activate. At a calibrated pressure, the valve allows fluid to pass and engages the front brakes. This valve is the same on all GM cars, but the bracket is different for applications...".

It should look like the one shown below:


If this valve is malfunctioning, the brakes can drag.

I would also say to be sure that you've eliminated the possibility of the front rubber brake lines being pinched by the brackets that hold the lines from fouling the suspension. These brackets are usually mounted on the lower control arm, and can rust up in their centers, causing a pinched hose over time, or can be damaged.

The hoses themselves can become delaminated in their ID, causing the pressure to the calipers to either not apply correctly or not release correctly.
04-11-2010 12:00 PM
schovil69
Brakes

I have a 1969 chevelle with the factory brake system installed, discs in front and drums in the rear.

Ten years ago I had a problem with the brakes sticking. I would drive the car normally and each time I applied the brake, it didn't release completely. It would take more and more gas pedal to get the car going and keep it going. Eventually the car wouldn't move and I would hop out, pop the hood, and bleed off the brake fluid pressure in the front line at the master cylinder.

There is a part just under the master cylinder that the front line goes to, not sure what it's called. I came to the conclusion that this was the culprit so I pulled it off and rebuilt it. This fixed the problem and I haven't had the issue come back to date.

My current issue:

My front wheels do not roll well. When I have the car in the air and spin a wheel, it quickly comes to a stop. Almost immediatley. I'm thinking the mystery part under the master cylinder is keeping pressure applied to the front brakes. I can be sitting on a hill in neutral and the car doesn't move or slowly goes down the hill, depending on the grade.

My question:

What is the mystery part under the master cylinder and can I remove it from the system and still have properly functioning brakes?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.