Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> Upper Ball Joint Trouble
User Name
Password
lost password?   |   register now

Thread: Upper Ball Joint Trouble Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-15-2010 10:05 AM
Camaro_Nut2001
help

Thanks, keep the help coming. I'm going out to the garage and check and try a few thing that have been suggested.
05-15-2010 05:14 AM
a1supersport You sure it's exactly the same? I did my ball joints/bushings on my '71 C20, then helped a friend do his '72 C10...and noticed the half-ton (C10) ball joints were smaller in diameter. They look identical as far as the taper of the joint, but the diameter was definitely smaller.

Other than that, another problem could be you can't get the spindle up high enough. Usually it's a problem if there's no engine/trans in the truck (not enough weight to compress the spring with a jack under the lower A-arm). If you have a spring compressor still on the spring, you should be able to get the ball joint in.
05-15-2010 05:11 AM
poncho62 You probably need to compress the spring a bit........Where is your jack stand sitting to support the lower "A" arm?......The further out toward the wheel it sits, the more it will compress the spring (leverage)......You may be able to pull the upper "A" frame down enough with a bar while someone else threads the nut on.
05-15-2010 01:02 AM
Camaro_Nut2001
Upper Ball Joint Trouble

Hello, I replaced my upper control arm shaft and bushings on my '69 C10 and new upper ball joint and new rubber bumper. The trouble is I can't get the new upper ball joint in the spindle enough to start my nut. I have tried a C-clamp and hammer and I can get it almost enough to feel a thread but I can't get it to go any further to get the nut on to tighten it up. I checked the ball joint to the old one and it's the same. Anyone got a trick to getting it in enough to get my nut on? Thank you

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.