Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Carter AFB
User Name
Password
lost password?   |   register now

Thread: Carter AFB Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-27-2010 07:38 AM
dcairns Give this guy a call, he is an expert in all things Carter and has rebuild kits that actually fit.

http://www.thecarburetorshop.com/
07-27-2010 05:51 AM
rachet ralph they are both a weber carb. cause back in the day if you pulled top off a carter AFB or AVS it said in the fuel bowl made by weber for carter an you look on the side the edelbrock carb says weber on it!
07-26-2010 05:16 PM
sickolds carter and edelbrock are the same thing
07-26-2010 03:24 PM
cobalt327 It isn't likely the bore has worn that much. It is possible the wrong pump is being used- Carter used 4 different accelerator pump diameters- 5/8" through 3/4" in 1/16" increments. And there are different lengths.

There's a chance it may be missing the spring that sits under the bottom "skirt" of the pump piston that holds the bottom edge out against the bore, if it is really close to fitting, but not quite. In this case, it would pump fuel, but just not well. And IIRC, not all pumps used that type spring.

Tip- Be sure the S-link to the pump is installed so that when viewed from the front, it looks like a correct "S", not a backwards "S".
07-26-2010 03:20 PM
Hippie Will the pump from an Edelbrock Performer fit?
07-26-2010 01:52 PM
marybill
Carter AFB

Accelerator pumps available to me locally are either too old or too small and won't make a decent seal in the bore despite soaking in oil and/or gas. I don't know if the bore is worn out or maybe I am not getting the correct pump. Anybody have any thoughts?......Bill

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 08:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.