Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> 70 Chevelle 350 TBI performance questions.
User Name
Password
lost password?   |   register now

Thread: 70 Chevelle 350 TBI performance questions. Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-10-2010 08:24 PM
bigdog7373 u will need a high pressure fuel pump for the tbi.
10-10-2010 07:45 PM
V8&4spd http://www.turbocity.com
10-10-2010 07:14 PM
Hacksaw
70 Chevelle 350 TBI performance questions.

HI, I have a 1970 Chevelle that just came back from paint. Im so excited that this car is ready to start building. Poor thing hasent seen pavement in over 20 years. Anyway, I am working on a 454 project that is going to take alot more $$$$ to finish. I really want to get this car going. A friend of mine gave me a 94 chevy k1500 4x4 truck with 200K miles on it. It runs but smokes on start up. It has the 350 TBI engine in it. Soooo, I thought about taking the engine out of it, and the complete wiring harness/computer, bolting it to my M21 4 speed, and putting this thing on the road. Keeping in mind that I will be installing the 454 in the car asap. I think I can rebuild the 350, scrap the heads for Vortecs, upgrade the cam and intake, and hopefully wake this engine up. I know that the factory computer will not handle the performance parts, but there must be some sort of reburn on the factory computer that can be done. Anyone done this before? And, if anyone is running this setup in their cars, please post pics... Thanks

Shawn

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 01:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.