Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Acceptable Piston Damage? possibly dropped...?
User Name
Password
lost password?   |   register now

Thread: Acceptable Piston Damage? possibly dropped...? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-16-2010 11:08 PM
dumbmechanic thanks guys for the quick responses
11-16-2010 10:36 PM
miller_time yup i agree run it. it will be fine
11-16-2010 09:48 PM
ericnova72 Unfortunate that it happened, but on the good side it doesn't really hurt anything, it is fine to use. A plus is that it is on the pin axis side, and not 90 to the pin which would put it on a thrust side.

Use it without worry.
11-16-2010 09:43 PM
68NovaSS I don't think it's as bad as it looks in the pictures. A purist would say nay, I think you're OK to polish it up and use it.
11-16-2010 09:19 PM
dumbmechanic
Acceptable Piston Damage? possibly dropped...?

I have read countless posts on this forum and respect its members opinions very much and now I have a question and really look foward to hearing from yall.

I just got my engine back from the machine shop. I gave them my pistons to balance the rotating assembly aswell as press on the con rods. Either one piston was dropped at the shop or shipped damaged (I don't care to speculate). I can see that when it landed on its side, it pressed up on the top/deck side of the piston. I did my best to get a focused picture (not easy). The owner of the machine shop took a file to it and mostly evened it out but this is what it still looks like.



What do you guys think? Thanks so much.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 07:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.