Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> need some friendly advice, fuel pump fuse problem
User Name
Password
lost password?   |   register now

Thread: need some friendly advice, fuel pump fuse problem Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-10-2010 08:13 PM
T-bucket23
Quote:
Originally Posted by untchable502
i have a 2001 ford windstar that has been idling off and on kinda weird.... well here in the last 2 weeks it has been starting to blow fuses that are to the fuel pump..... are these 2 things symptoms of the fuel pump going bad or is it a different issue.... any advice would be great dont really want to drop 160 on a fuel pump if thats not the issue... thanks in advance
Fuel pump or wiring to it. If you cant find anything in the wiring then I would change the pump
12-10-2010 07:39 PM
untchable502
need some friendly advice, fuel pump fuse problem

i have a 2001 ford windstar that has been idling off and on kinda weird.... well here in the last 2 weeks it has been starting to blow fuses that are to the fuel pump..... are these 2 things symptoms of the fuel pump going bad or is it a different issue.... any advice would be great dont really want to drop 160 on a fuel pump if thats not the issue... thanks in advance

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 11:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.