Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering> Combination brake distribution block
User Name
Password
lost password?   |   register now

Thread: Combination brake distribution block Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-22-2011 11:35 AM
krruzer
Combination brake distribution block

I'm working on a brake problem on a new project. Front disc( new front clip) rear drums. New 7" dual booster, Corvette style master and a combination valve(Gearhead) mounted below the master, both on firewall 6 to 1 pedal ratio new lines including braided front lines . My question is 2 fold one, the combination valve. It has a rubber covered valve where the front brake lines exit what is this for and suppose to do? Secondly I can't get a good pedal When engine off there seems to have some resistance in the pedal however, when engine is running the first few inches of pedal movement seems to be without resistance. have done all the checks, pin to booster, vacuum power, bleed ,gravity bleed, manual bleed. still no brakes to speak of. Calipers have valves on the up side.I did buy a set of used calipers and dropped spindles at a swap meet they appeared to be O K. The rear drum shoes have been adjusted to the drums for a snug fit. I know I'm rambling on just try to list all the variables. Any advise appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 05:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.