Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Body - Exterior> SPI Universal clear....WOW
User Name
Password
lost password?   |   register now

Thread: SPI Universal clear....WOW Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-12-2011 01:41 PM
texastomeh
Quote:
...even if the clear and epoxy was just average the sales and service alone is enough to have me hooked.....
DITTO from Dallas.

I just finished swapping emails with Barry re compatability of SPI Universal Clear with a water based 100% Acrylic Base Coat (it is - with a little common sense), and it is SUNDAY!!

Try THAT with some of the other guys!!

Tom
06-12-2011 10:40 AM
deadbodyman OK,I'm in ....SPI universal clear over Blk chroma base...Before cut & buff..
Lot car...SPI again over RED Nason ful base..no cut & buff....and they say Nason cant be blended..
I started using SPI about seven yrs ago because of the price.since then I've tried most of thier products,they all preform well at a good price but thier clear and epoxy primer stand head and shoulders above the rest at ANY price...Theres only a few companies that have earned this amount of praise but of them SPI is at the top and I havent even gotten into thier service at all ...even if the clear and epoxy was just average the sales and service alone is enough to have me hooked.....
06-11-2011 06:45 PM
mr4speed Here are a few more
06-11-2011 06:42 PM
mr4speed Here are some pics of the cad and one of the 55 chevy
06-11-2011 02:13 PM
bighotroddin Checked out the website definitly worth getting some. I am about a 1/2 from Milwaukee but will call the company to see if anyone one carries it.
06-11-2011 08:52 AM
swvalcon
bighotroddin

If your on the west side of wi there's a guy in mn that ships to you. Name is auto parts city.
06-11-2011 07:53 AM
Old Fool
Quote:
Originally Posted by bighotroddin
Where can you get the SPI clear at and whats the price?

I have been usinf Acme Finish 1 clear made by Sherwin Williams for a while now since Finish master stopped selling Smart brand clear. Workes great for the used cars. On the other stuff I use Deltron DC 4000.
Call them and see if you have a local vendor. If they do not have one near you they will ship direct to your door - no shipping charges!

SPI 706-781-2220

Visit their website: http://www.southernpolyurethanes.com/
06-10-2011 09:06 PM
bighotroddin Where can you get the SPI clear at and whats the price?

I have been usinf Acme Finish 1 clear made by Sherwin Williams for a while now since Finish master stopped selling Smart brand clear. Workes great for the used cars. On the other stuff I use Deltron DC 4000.
06-08-2011 06:28 PM
jeremyb
Quote:
Originally Posted by panelwagon62
Now that is sexy, how many coats total is that?
3 coats of universal, cut with 800 all the way to 3000.

get those factory gun air pressure settings out of your head. no 2 clears spray the same. i'm at about 28-30 on my w400.

just a side note, w400 is my main clear gun but on that vette i did use my lph400 1.4 because the w took a dump on me at that particular time. They both lay the clear great, just the w400 is faster and fits my style better.
06-08-2011 05:45 PM
Old Fool
Quote:
Originally Posted by 67Elcamino
Im not an expert and do not have much experience shooting clears. Im just wondering if I need more PSI. I noticed that when I use the PSI setting recommended by the gun it barely shoots paint. When I increase the psi a bit seems to work fine. Will this PSI effect the finish and create orange peel in the clear. I noticed by watching some videos of people shooting clear its shoots very misty. Maybe Im laying too thick.. Im going to test and adjust my gun before starting next time. I just purchases a gun with 1.4 tip
crank the air up to 25-30 at the inlet to the gun. Better yet toss the gun in the garbage and get a top end gun.

http://www.hotrodders.com/forum/pick...un-198570.html
06-08-2011 10:06 AM
panelwagon62
Quote:
Originally Posted by jeremyb
i use an iwata w400lv 1.4 for spraying. Unreduced. Just mix 1-1 with activator.

Depending on the job at hand, i start cutting with 800 or 1000. Work my way up to 3000 trizact and use mequiars diamond cut compound and a wool pad.

I let the car sit in the sun a full day before cutting, then let it sit another full day after the initial 800-1000 cut.

this is after just the wool pad.

Now that is sexy, how many coats total is that?
06-08-2011 05:32 AM
jcclark Most HVLP's work better with a little higher PSI.
I'm starting to think the mfg recommended pressure is more for
enviromental reasons than spray quality.
06-07-2011 11:22 PM
mitmaks You adjust gun to work for YOU not the other way around
06-07-2011 10:39 PM
67Elcamino Im not an expert and do not have much experience shooting clears. Im just wondering if I need more PSI. I noticed that when I use the PSI setting recommended by the gun it barely shoots paint. When I increase the psi a bit seems to work fine. Will this PSI effect the finish and create orange peel in the clear. I noticed by watching some videos of people shooting clear its shoots very misty. Maybe Im laying too thick.. Im going to test and adjust my gun before starting next time. I just purchases a gun with 1.4 tip
06-07-2011 06:26 PM
chas350 sounds like your gun may need a good cleaning?
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.