Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> BBC Starter problem
User Name
Password
lost password?   |   register now

Thread: BBC Starter problem Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-04-2011 07:56 AM
eloc431962
Quote:
Originally Posted by troy norrad
Better start counting teeth on old flexplate and see if the same number comes up ?
X2 re-count the teeth and get the correct starter to match.



Cole
07-04-2011 06:46 AM
Ratoflic
Quote:
Originally Posted by troy norrad
Better start counting teeth on old flexplate and see if the same number comes up ?
Hi Troy,

That's a 168 tooth, the starter is a 153/168 tooth...that's the same flexplate
06-30-2011 03:18 PM
troy norrad Better start counting teeth on old flexplate and see if the same number comes up ?
06-13-2011 10:24 AM
Ratoflic
BBC Starter problem

One of my friend have a BBC and have a starter problem.

With the old block (454) with the same starter and Flexplate the car start really fine, no trouble at all....we put the same starter/flexplate on the new block...and the trouble begin.....we had to change the flexplate..because the teeth was damaged...the starter bendix seem to not touch really the flywheel tooth......so everything is always broken..

Does somebody can help us.....

PS, this car have 12.5 CR and around 650hp...

Thanks, Stephane

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.