Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical> Battery went dead sitting, What to check?
User Name
Password
lost password?   |   register now

Thread: Battery went dead sitting, What to check? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-01-2011 04:11 PM
eric32 Hello guys thanks for the tip. I already have one of those and I used it and unhooked the battery ground wire and put it to the positive cable and it did not light up but the battery emblem on my dash would not go off until the battery was unhooked of course and I discovered that a wire hooked up to my alternator was causing my dash battery indicator to stay on even with key out as it was drawing constant power somehow.

I thought the wire hooked up to my alternator was for my dash volt meter but turns out it was not so I took it off and problem solved.

The battery indicator does not come on now just when you start it and it then will go off and nothing is on while truck is off.

I also had everything checked at the auto store and they checked alternator,battery and all is good. Thanks a lot guys for the tricks

I learned something new from this.
Take care
Eric
07-01-2011 03:59 AM
EOD Guy Go to Auto parts store and get the battery checked, could just be starting to go bad, just because it's 2 yrs old doesn't mean crap.
06-30-2011 09:56 PM
evolvo OK, get one of these http://www.stu-offroad.com/electrica...t/tlight-1.jpg. Then disconnect the Negative battery cable from the - post. Connect the test light between the - cable clamp and the - battery post. Is the test light lit up? If it is you have a short/drain in your system, could be that instrument light, if it's really bright you have a big draw, not so bright just a little draw. Now start pulling fuses one at a time. When the light goes out you've found the short/drain. See what the fuse controls and start tracing out the wires in that circuit. Could be something as simple as the ciggy lighter stuck, I've been paid to fix that one (!) or something more complicated. Good Luck
06-30-2011 05:34 PM
eric32
Battery went dead sitting, What to check?

Hello guys I went out to start my truck today and for some reason my battery was almost dead at only 10 volts showing when you turn the key forward in the start position so I know something drained it. I had to get a jump.

This is a carbureted v8 96 s10 and not using any gauges in dash area as I have a set of aftermarket gauges. I drove my truck last Friday and everything was charging and working just fine with no issues. I have not driven it since then. Everything on charging system is brand new and battery is less then two years old and it was fully charged last week.

I did have some sort of problem with my chime staying on while the dash light was on while running headlights but if I turned the dash light dimmer switch to the off position to shut dash light off it would go off. Now while running the lights the chime sometimes would keep quiet. Anyways that should not be the problem as the only change I did to my truck since last week was take out the chime box under my dash and nothing else.

I looked over everything in my truck and there was no light's on inside anywhere and the key was in the correct position when I took it out. Now I don't know if this is causing the drain or not but on my dash there is nothing on but for some reason the battery indicator light stays on even with no keys in the truck and heck I never paid attention before but to me it seems that should not be showing with nothing on or running correct?

So if this is the problem can just that little indicator not shutting off drain my battery by not wanting to shut off? I never paid attention before cause only gauge that works in dash is the volt gauge. Hope someone can help me out on what the heck to check for cause everything else is working as normal and all lights turn off when the key is off.

Thanks guys
Eric

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 11:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.