Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Timing / Idle
User Name
lost password?   |   register now

Thread: Timing / Idle Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-16-2011 02:53 PM

Thanks for all the responses. I'll call him over and have him take a look at it.
08-16-2011 01:34 PM
cool rockin daddy Sir, if you understand that you don't set the idle by changing the initial timing, you should understand that you don't change the timing by adjusting the idle! You have to adjust the idle speed screw to adjust the idle speed.
08-16-2011 01:04 PM

Right, I understand that. I may have said it wrong. I guess my question should have been how can I tell if my timing is set with too much advance? I'm hoping it's just a matter of adjusting the idle. Thanks for the reply.
08-16-2011 12:58 PM
WDCreech You don't set the idle by changing the initial timing! There is a screw, on the Carurator throttle linkage to adjust how low the idle is set. Usually it will have a spring to keep tension on it so that it doesn't unscrew itself from vibration.
08-16-2011 12:32 PM
Timing / Idle

Ok, I got the ignition problem straightened out, and the new T5 transmission in the my 88 Mustang(302). I pulled it out the garage the day and took it around the block. Ran good, did'nt go too far because of those 4.56 gears in the rear that I'm trying to get rid of. My question is this. I had a buddy of mine set my timing. He has a local mechanic shop and runs two race cars on dirt tracks, so I kno he's pretty knowledgable. But it seems to me that the timing is set too high! It's a smooth idle, but it's just so high. Sounds like the car is revved too high. I'm not sure how to distinguish whether I can adjust the idle on the carb and correct the problem, but the distributor a little, or do I need to have the timing completely reset. I thought the timing should have been 10 BTDC, but I know he set it at something different. Any suggestions? He's a die hard Chevy, so maybe he set the timing thinking about a Chevrolet, I don't know. But I do know that the engines seems to be revving too high. The tach is not working, so I could'nt tell you want range it's idling at.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -6. The time now is 02:08 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright 1999 - 2012. All Rights Reserved.