Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Garage - Tools> Compressor Problem...
User Name
Password
lost password?   |   register now

Thread: Compressor Problem... Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-29-2011 02:58 PM
S10xGN I'm considering this, but IIRC the gasket kit for the heads was over $150. I may give it a shot after it cools off some...

Thanks!

Russ
09-28-2011 11:25 AM
OneMoreTime You may have a broken reed..i had one and got a piece of tempered spring stock from McMaster Carr and made a new reed..back to working now...only about 20$ IIRC..

Sam
09-28-2011 11:08 AM
S10xGN
Compressor Problem...

Hi All,

I have a 7.5 HP Northern brand 29 CFM compressor about 6 yrs old. For the past few months, the interstage safety valve pops off a couple times whenever the unit shuts off. I changed out the discharge/check valve and it still pops. To me, this would indicate the 2nd stage reeds are not seating off and the full discharge pressure (175 PSI) is bleeding back into the 1st stage (PSV set at 80 PSI). There is no other problem of note. I've priced a rebuild kit and it's over $600! A whole new pump assembly is $750. I'm planning on just leaving it as-is until it no longer keeps up. Any thoughts or ideas?

Thanks!

Russ

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.