Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend> T-350 front leak ?
User Name
Password
lost password?   |   register now

Thread: T-350 front leak ? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-30-2011 08:27 PM
rlb3
Quote:
Originally Posted by 10scnd70
Chevrolet 350 speedo o-ring is the same size. I use Permatex Ultra Copper on anything transmission related. It doesn't break down when introduced to transmission fluid.

Frank
Thanks for the help, I will go to the auto store tomorrow after work and get a oring and the copper stuff and a pan gasket
09-30-2011 08:12 PM
10scnd70 Chevrolet 350 speedo o-ring is the same size. I use Permatex Ultra Copper on anything transmission related. It doesn't break down when introduced to transmission fluid.

Frank
09-30-2011 07:59 PM
rlb3
Quote:
Originally Posted by 10scnd70
Yes, the lock-up plug has an o-ring. You'll have to drop the pan to collapse the retaining fingers that hold the plug in the case.

Frank
Ok that's great can I just use any kind of o-ring to seal it?, also should I put some sealant or something on the o-ring before installing it
09-30-2011 07:35 PM
10scnd70 Yes, the lock-up plug has an o-ring. You'll have to drop the pan to collapse the retaining fingers that hold the plug in the case.

Frank
09-30-2011 07:00 PM
rlb3 I finally crawled under the truck and majorly cleaned the trans, I found that the leak is actually from the tourqe converter lock up plug that is on the driver side, is there a o ring or sumthing like that to seal, or how do I fix this?
09-30-2011 03:07 PM
rlb3
Quote:
Originally Posted by 10scnd70
There are numerous places a TH350 could leak. Even if you replaced the seal, there's a chance the pump bushing could have walked forward, which will cause a leak. Did you put silicone around the pump seal when you installed it? The pump has an o-ring that seals it to the case that have been known to leak. And...Don't overlook the converter hub. I've seen many of these crack at the welds. Most of the time, where the hub is welded on. The other possiblity are the pump bolts. Does it leak more while running or with the engine off?

Frank
It leaks more with the engine off. , i put the seal in dry
09-30-2011 11:07 AM
10scnd70 There are numerous places a TH350 could leak. Even if you replaced the seal, there's a chance the pump bushing could have walked forward, which will cause a leak. Did you put silicone around the pump seal when you installed it? The pump has an o-ring that seals it to the case that have been known to leak. And...Don't overlook the converter hub. I've seen many of these crack at the welds. Most of the time, where the hub is welded on. The other possiblity are the pump bolts. Does it leak more while running or with the engine off?

Frank
09-30-2011 07:11 AM
delawarebill
tranny leak

i'm no tranny exp by no means... but i still be look'n at the front seal.. maybe the input shaft bearing/bushing is going bad and do'n a wobble on the seal.. napa has them too...
09-29-2011 10:26 PM
rlb3
T-350 front leak ?

I bougt a th350c and I put a new front seal in it, after I installed the trans it didn't leak at all but after driving a couple times the trans started leaking in the front, it just seems like its getting worse and worse, where could it be leaking from? The fluid is leaking exactly in the middle of the front of the trans, I wouldn't think it was the seal but I'm not sure. Any ideas?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 04:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.