Hot Rod Forum : Hotrodders Bulletin Board - Reply to Topic
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> my truck's dead at dead and sitting at the gas station
User Name
Password
lost password?   |   register now

Thread: my truck's dead at dead and sitting at the gas station Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-05-2003 08:43 PM
antirice we're just gonna replace the whole pump and call it good, thanks for all the help guys
09-05-2003 08:39 PM
drlindz Since it started after you got it home, I would suspect the fuel pump relay. Had an Oldsmobile that had the same problem then mysteriously started the next day. Happened a few more times before I discovered the bad relay.
09-05-2003 05:26 PM
Indian I was thinking module as well
09-05-2003 04:29 PM
antirice we towed it home, and it started right up so we're befuddled!
09-05-2003 03:44 PM
gumby one of three things most likely. fuel pump, coil, or module in the distributor. One of these three things should work
09-05-2003 03:07 PM
malc Try changing the module in the HEI distributor,I had just the same problem and doing that worked.
09-05-2003 02:31 PM
roys63 If you have spark Have someone crank it and hit the bottom center of the gas tank with a hammer , may get the fuel pump running long enough to get it home , if it is the pump, we do this all the time to move vehicle's in to the shop and this is the first thing we check on a no start like this, sounds funky but it works most of the time if its the pump. If no spark check the coil we change a lot of coils on the GMs .
09-05-2003 02:06 PM
DragTour69XL Like the others have said, you’re not getting a spark, gas, and air. It is one of those three.

Pull the air filter completely out. If the filter is clogged it will choke a warm car.

Check for spark at a plug. Ether you have it or you don't.

Shoot some starting fluid where the air intake is. If it starts, you know the issue is fuel.

Once you know which of the three it is, let us know and we can trap the issue.
09-05-2003 01:58 PM
engineczar as nasty as the stuff is, spray some starting fluid into the throttle body and try starting it, if it kicks like it wants to start then it's fuel related (pump, filter, no gas) if it does nothing but turn over then it's ignition (no spark) or mechanical (timing chain)
09-05-2003 01:21 PM
antirice 1) its got EFI

2) I let it sit and tried to start it 5 different times
09-05-2003 01:15 PM
Indian Did you try sarting the truck after the engine had ample time to cool??
09-05-2003 01:14 PM
johnsongrass1 See if it's getting gas at the carb and if it is try seeing if it has spark at the plugs.
09-05-2003 12:08 PM
antirice
my truck's dead and sitting at the gas station

help guys, I got off the highway and stopped at the gas station to get a Pepsi, I walk back out to the truck and try to start it, it turns over but won't start, I didn't notice anything before I shut it off, any ideas?

the truck is an '88 GMC fullsize longbed, 305 with 109,000 miles

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 06:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.